summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-24 05:43:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-24 05:59:35 +0200
commite5d757709a05169e4f1d87baf17358aab0dd8bb1 (patch)
tree65ba11fa1f3c85ba1c7894586749ea060a63d9e8 /gnu/packages/shells.scm
parentd0d3ed6dfccb9934a90caf29861e4dac09faec2b (diff)
downloadguix-patches-e5d757709a05169e4f1d87baf17358aab0dd8bb1.tar
guix-patches-e5d757709a05169e4f1d87baf17358aab0dd8bb1.tar.gz
gnu: loksh: Don't use unstable tarball.
* gnu/packages/shells.scm (loksh)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8362d00f60..7a7f2ae2bd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -572,13 +572,13 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(version "6.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/dimkr/loksh/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimkr/loksh.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0i1b60g1p19s5cnzz0nmjzjnxywm9szzyp1rcwfcx3gmzvrwr2sc"))))
+ (base32 "0hx57y73g807x321wpa6sr0vvw6igwhaq88rrdryjjbw6p4k0vcc"))))
(build-system gnu-build-system)
(inputs
`(("libbsd" ,libbsd)))