summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-18 16:55:12 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-05-20 02:42:04 +0200
commitcc5a76a74c5042a3dff894cdd64ad0399ffd963c (patch)
tree529cd76408cdb888553e9d5dcdbb15562c742516 /gnu/packages/shells.scm
parent70f8242b13099697e69e0ad5863bc71ad6b18782 (diff)
downloadguix-patches-cc5a76a74c5042a3dff894cdd64ad0399ffd963c.tar
guix-patches-cc5a76a74c5042a3dff894cdd64ad0399ffd963c.tar.gz
gnu: Add loksh.
* gnu/packages/shells.scm (loksh): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 4e684e8c81..47d3a46148 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages documentation)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libedit)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
@@ -457,3 +458,39 @@ components: a process notation for running programs and setting up pipelines
and redirections, and a complete syscall library for low-level access to the
operating system.")
(license bsd-3))))
+
+(define-public loksh
+ (package
+ (name "loksh")
+ (version "6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dimkr/loksh/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wg7ds56yr8fgg1m149bi53bvrwccwiashmwknggza1sqgj9m2lq"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libbsd" ,libbsd)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f ;No tests included
+ #:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "PREFIX=")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ;No configure script
+ (home-page "https://github.com/dimkr/loksh")
+ (synopsis "Korn Shell from OpenBSD")
+ (description
+ "loksh is a Linux port of OpenBSD's @command{ksh}. It is a small,
+interactive POSIX shell targeted at resource-constrained systems.")
+ ;; The file 'LEGAL' says it is the public domain, and the 2
+ ;; exceptions which are listed are not included in this port.
+ (license public-domain)))