summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-07-02 23:27:04 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-02 23:54:02 +0200
commitaf74c0633aa62d7d4e341920cfa3265f27f793cf (patch)
treeed682af020dfd7a002208909a6cd3b04fbecbb00 /gnu/packages/shells.scm
parent2807a8432aa2aaac6fa7024974be6468ca1160b5 (diff)
downloadguix-patches-af74c0633aa62d7d4e341920cfa3265f27f793cf.tar
guix-patches-af74c0633aa62d7d4e341920cfa3265f27f793cf.tar.gz
gnu: gash, gash-utils: Build with Guile 3.0.
* gnu/packages/shells.scm (gash)[source]: Add 'modules' and 'snippet'. [inputs]: Change GUILE-2.2 to GUILE-3.0. (gash-utils)[source]: Add 'modules' and 'snippet'. [inputs]: Change GUILE-2.2 to GUILE-3.0. * gnu/packages/commencement.scm (gash-utils-boot)[source]: Remove unneeded 'modules' field, and add 'snippet'. (gash-utils-boot)[source]: New field. * gnu/packages/patches/gash-utils-ls-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm24
1 files changed, 20 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 109baacc30..b790a0cc18 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -856,12 +856,19 @@ scripts.")
(sha256
(base32
"13m0yz5h9nj3x40mr6wr5xcpq1lscndfwcicw3skrz801025hhgf"))
- (modules '((guix build utils)))))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure"
+ (("search=\"2\\.2 2\\.0\"")
+ "search=\"3.0 2.2 2.0\""))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-3.0)))
(arguments
'(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
(home-page "https://savannah.nongnu.org/projects/gash/")
@@ -882,12 +889,21 @@ as part of the Guix bootstrap process.")
version ".tar.gz"))
(sha256
(base32
- "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))))
+ "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))
+ (patches (search-patches "gash-utils-ls-test.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure"
+ (("search=\"2\\.2 2\\.0\"")
+ "search=\"3.0 2.2 2.0\""))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-2.2)
+ `(("guile" ,guile-3.0)
("gash" ,gash)))
(home-page "https://savannah.nongnu.org/projects/gash/")
(synopsis "Core POSIX utilities written in Guile Scheme")