summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-04 15:08:13 -0400
committerLeo Famulari <leo@famulari.name>2018-09-04 18:10:53 -0400
commit95681e55862991a5303449a4eb3961441b337033 (patch)
treeff51fbf1a68357ec14bf762d18403441e151abf4 /gnu/packages/shells.scm
parentca719424455465fca4b872c371daf2a46de88b33 (diff)
downloadguix-patches-95681e55862991a5303449a4eb3961441b337033.tar
guix-patches-95681e55862991a5303449a4eb3961441b337033.tar.gz
gnu: Zsh: Update to 5.6 [fixes CVE-2018-{0502,13259}].
* gnu/packages/shells.scm (zsh): Update to 5.6. [arguments]: Skip some tests.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 6dbe1c4db7..c3647221aa 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -292,7 +292,7 @@ history mechanism, job control and a C-like syntax.")
(define-public zsh
(package
(name "zsh")
- (version "5.5.1")
+ (version "5.6")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -303,7 +303,7 @@ history mechanism, job control and a C-like syntax.")
".tar.xz")))
(sha256
(base32
- "105aqkdfsdxc4531anrj2zis2ywz6icagjam9lsc235yzh48ihz1"))))
+ "1mp6h2452z2029n12mxipjv4b0cc8i8sb72g8p8jklg8275iysvl"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
#:phases
@@ -336,6 +336,11 @@ history mechanism, job control and a C-like syntax.")
(("command -pv") "command -v")
(("command -p") "command ")
(("'command' -p") "'command' "))
+ ;; Several of these tests fail spuriously in the Guix
+ ;; build environment due to assumptions about PATH and
+ ;; the location of the test files. It was easier to just
+ ;; skip them than try to make them work.
+ (delete-file "Test/A05execution.ztst")
#t)))))
(native-inputs `(("autoconf" ,autoconf)))
(inputs `(("ncurses" ,ncurses)