summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-07-12 19:32:51 +0000
committerLeo Famulari <leo@famulari.name>2017-07-22 20:15:21 -0400
commit7e3c977da6ea15acfad361200cdde12636406b61 (patch)
tree26aafaf4422171acc425c03a8e5677d59a967241 /gnu/packages/shells.scm
parent36378bd57ec31ba2bbedbdbdbd77b5b0f82f3b8a (diff)
downloadguix-patches-7e3c977da6ea15acfad361200cdde12636406b61.tar
guix-patches-7e3c977da6ea15acfad361200cdde12636406b61.tar.gz
gnu: Add oksh.
* gnu/packages/shells.scm (oksh): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c66c575c18..8d2a957eae 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 ng0 <ng0@no-reply.infotropique.org>
+;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
@@ -553,6 +553,29 @@ extra programs. > is just another unix command, < is essentially cat(1).
A @code{andglob} program is also provided along with s.")
(license bsd-3))))
+(define-public oksh
+ (package
+ (name "oksh")
+ (version "0.5.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://connochaetos.org/oksh/oksh-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ln9yf6pxngsviqszv8klnnvn8vcpplvj1njdn8xr2y8frkbw8r3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(; The test files are not part of the distributed tarball.
+ #:tests? #f))
+ (home-page "https://connochaetos.org/oksh")
+ (synopsis "Port of OpenBSD Korn Shell")
+ (description
+ "Oksh is a port of the OpenBSD Korn Shell.
+The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
+ (license gpl3+)))
+
(define-public loksh
(package
(name "loksh")