summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-02 22:48:34 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 00:39:50 +0100
commit6133217c16734be7fd937a7d5043b2f61eb02493 (patch)
treecbd1e8647822b560f5dacddf108026cc00eeb431 /gnu/packages/shells.scm
parent07334e83fc1f78906a831a4b6fe3873822351043 (diff)
downloadguix-patches-6133217c16734be7fd937a7d5043b2f61eb02493.tar
guix-patches-6133217c16734be7fd937a7d5043b2f61eb02493.tar.gz
gnu: mksh: Update to 59c.
* gnu/packages/shells.scm (mksh): Update to 59c. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index a0436f6c56..642682ec8e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -791,14 +791,14 @@ interactive POSIX shell targeted at resource-constrained systems.")
(define-public mksh
(package
(name "mksh")
- (version "58")
+ (version "59c")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R"
version ".tgz"))
(sha256
- (base32 "1337zjvzh14yncg9igdry904a3ns52l8rnm1kcq262w7f5xyp2v0"))))
+ (base32 "01n5ggw33bw4jv4d3148wlw9n4aj7vdn3ffnc66c9w9pldjidbkp"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; tests require access to /dev/tty
@@ -817,8 +817,7 @@ interactive POSIX shell targeted at resource-constrained systems.")
(install-file "mksh" bin)
(with-directory-excursion bin
(symlink "mksh" "ksh"))
- (install-file "mksh.1" man)
- #t))))))
+ (install-file "mksh.1" man)))))))
(home-page "https://www.mirbsd.org/mksh.htm")
(synopsis "Korn Shell from MirBSD")
(description "mksh is an actively developed free implementation of the