summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-17 14:42:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-18 13:50:09 +0200
commit487cf5aaf620fa56ddc76c854a34289dfdf04e93 (patch)
tree62ae98e661c9b8cc833803a8505b82942311d1d4 /gnu/packages/shells.scm
parent7c0ed27a8bc49ff80ec7e52f1f0b145815e0abc1 (diff)
downloadguix-patches-487cf5aaf620fa56ddc76c854a34289dfdf04e93.tar
guix-patches-487cf5aaf620fa56ddc76c854a34289dfdf04e93.tar.gz
gnu: rc: Simplify.
* gnu/packages/shells.scm (rc)[source]: Replace magic commit ID with the tagged release. Use GIT-FILE-NAME. [arguments]: Remove 'autoreconf' phase (relying on Guix's built-in 'bootstrap' phase instead) and adjust the ordering of 'patch-trip.rc' accordingly.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 406766351c..245496aaaf 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -155,23 +155,18 @@ and syntax highlighting.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/rakitzis/rc.git")
- ;; commit name 'release: rc-1.7.4'
- (commit "c884da53a7c885d46ace2b92de78946855b18e92")))
+ (commit (string-append "v" version))))
(sha256
(base32
- "00mgzvrrh9w96xa85g4gjbsvq02f08k4jwjcdnxq7kyh5xgiw95l"))
- (file-name (string-append name "-" version "-checkout"))))
+ "0vj1h4pcg13vxsiydmmk87dr2sra9h4gwx0c4q6fjsiw4in78rrd"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
'("--with-edit=gnu")
#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'autoreconf
- (lambda _ (zero? (system* "autoreconf" "-vfi"))))
- (add-before
- 'autoreconf 'patch-trip.rc
+ (add-before 'bootstrap 'patch-trip.rc
(lambda _
(substitute* "trip.rc"
(("/bin/pwd") (which "pwd"))