summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-06-01 14:47:56 -0400
committerTimothy Sample <samplet@ngyro.com>2019-06-01 14:47:56 -0400
commit2ccc9d692aed72dab614ab684341ca76466eafdf (patch)
tree35b5c0272edc29f7d6fdd5a1dfce7e25092dba58 /gnu/packages/shells.scm
parenta0c3a2e3a1a37884f795542d1cc8fb4b7bb227ac (diff)
downloadguix-patches-2ccc9d692aed72dab614ab684341ca76466eafdf.tar
guix-patches-2ccc9d692aed72dab614ab684341ca76466eafdf.tar.gz
gnu: Add gash.
* gnu/packages/shells.scm (gash): New variable.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 9ed983db98..3512c5ac46 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages documentation)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libedit)
#:use-module (gnu packages ncurses)
@@ -789,3 +791,27 @@ is commonly written.")
(home-page "https://www.oilshell.org/")
(license (list psfl ; The Oil sources include a patched Python 2 source tree
asl2.0))))
+
+(define-public gash
+ (package
+ (name "gash")
+ (version "0.1")
+ (source
+ (origin (method url-fetch)
+ (uri (string-append "mirror://savannah/gash/gash-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00m3lif64zyxd41cnk208kc81nl6qz659676qgiaqgwrw0brzrid"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://savannah.nongnu.org/projects/gash/")
+ (synopsis "POSIX-compatible shell written in Guile Scheme")
+ (description "Gash is a POSIX-compatible shell written in Guile
+Scheme. It provides both the shell interface, as well as a Guile
+library for parsing shell scripts. Gash is designed to bootstrap Bash
+as part of the Guix bootstrap process.")
+ (license gpl3+)))