summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-05 18:14:12 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:57 +0200
commit2b9ef6e5ef13a4f17312633e514f034f7fd6f155 (patch)
tree79f176d1f46090bb4bec7cc1d8e1aea9da3d3fad /gnu/packages/shells.scm
parent5fd395db3f6b425a04675b96279f92ea86aa1c54 (diff)
downloadguix-patches-2b9ef6e5ef13a4f17312633e514f034f7fd6f155.tar
guix-patches-2b9ef6e5ef13a4f17312633e514f034f7fd6f155.tar.gz
gnu: tcsh: Fix cross-compilation.
* gnu/packages/shells.scm (tcsh)[arguments]: Replace "cc" by "gcc" as native gethost compiler when cross-compiling.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0579c167fc..cf578151b4 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -356,6 +357,14 @@ written by Paul Haahr and Byron Rakitzis.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ,@(if (%current-target-system)
+ '((add-before 'configure 'set-cross-cc
+ (lambda _
+ (substitute* "configure"
+ (("CC_FOR_GETHOST=\"cc\"")
+ "CC_FOR_GETHOST=\"gcc\""))
+ #t)))
+ '())
(add-before 'check 'patch-test-scripts
(lambda _
;; Take care of pwd