summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-20 04:13:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-20 04:17:04 +0200
commit2385ecb22450f7d6671013808df1398945b80264 (patch)
tree9f73426f350ab9a5ee66df71309e01bf8345544b /gnu/packages/shells.scm
parent9923d5a40fa3e5950c2291d84b34961af497294e (diff)
downloadguix-patches-2385ecb22450f7d6671013808df1398945b80264.tar
guix-patches-2385ecb22450f7d6671013808df1398945b80264.tar.gz
Use INVOKE in (gnu packages shells).
* gnu/packages/shells.scm (mksh)[arguments]: Use INVOKE... (scsh)[arguments]: ...and also return #t from all phases.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 245496aaaf..8362d00f60 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -417,7 +417,7 @@ use of experts and novices alike.")
#t))
(add-after 'unpack 'autoreconf
(lambda _
- (zero? (system* "autoreconf")))))))
+ (invoke "autoreconf"))))))
(inputs
`(("scheme48" ,scheme48)
("scheme48-rx" ,scheme48-rx)))
@@ -623,7 +623,7 @@ interactive POSIX shell targeted at resource-constrained systems.")
(replace 'build
(lambda _
(setenv "CC" "gcc")
- (zero? (system* (which "sh") "Build.sh"))))
+ (invoke (which "sh") "Build.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -632,7 +632,8 @@ interactive POSIX shell targeted at resource-constrained systems.")
(install-file "mksh" bin)
(with-directory-excursion bin
(symlink "mksh" "ksh"))
- (install-file "mksh.1" man)))))))
+ (install-file "mksh.1" man)
+ #t))))))
(home-page "https://www.mirbsd.org/mksh.htm")
(synopsis "Korn Shell from MirBSD")
(description "mksh is an actively developed free implementation of the