summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-04-26 11:10:01 +0000
committerLudovic Courtès <ludo@gnu.org>2017-05-03 23:50:15 +0200
commit1dc0a66591f4fb37fc0df2aec6d3b0b7e2046c70 (patch)
treef5706fcc989d17335b36b25df2043138b73b1a4f /gnu/packages/shells.scm
parent0ea45ef4226a0b70bee5c2fad700e9e188dfa88f (diff)
downloadguix-patches-1dc0a66591f4fb37fc0df2aec6d3b0b7e2046c70.tar
guix-patches-1dc0a66591f4fb37fc0df2aec6d3b0b7e2046c70.tar.gz
gnu: Add fish-guix.
* gnu/packages/shells.scm (fish-guix): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 012f272ca4..5f57619e02 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
@@ -147,6 +147,32 @@ highlighting.")
(home-page "https://fishshell.com/")
(license gpl2)))
+(define-public fish-guix
+ (package
+ (name "fish-guix")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.pragmatique.xyz/fish-guix/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0xi0j9lvzh43lrj82gz52n2cjln0i0pgayngrg4hy5w4449biy0z"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No checks.
+ #:make-flags (list
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; No configure script.
+ (home-page "https://pragmatique.noblogs.org/software/fish-guix/downloads/")
+ (synopsis "Fish completions for Guix")
+ (description
+ "Fish-guix provides completions for Guix for users of the fish shell.")
+ (license public-domain)))
+
(define-public rc
(package
(name "rc")