summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:25:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:27:51 +0200
commit075df3d3e2f86ad2548075969b34402a3c40ec42 (patch)
tree303b422a84ce5ee1fccff610eaf83b20919e8b87 /gnu/packages/shells.scm
parentaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (diff)
parentb2721c3656e0ddf76dcccccfbacaaa309d2f47fe (diff)
downloadguix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar
guix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index acc5ac9e49..7b3f463945 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -803,14 +803,14 @@ interactive POSIX shell targeted at resource-constrained systems.")
(define-public mksh
(package
(name "mksh")
- (version "58")
+ (version "59c")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R"
version ".tgz"))
(sha256
- (base32 "1337zjvzh14yncg9igdry904a3ns52l8rnm1kcq262w7f5xyp2v0"))))
+ (base32 "01n5ggw33bw4jv4d3148wlw9n4aj7vdn3ffnc66c9w9pldjidbkp"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; tests require access to /dev/tty
@@ -829,8 +829,7 @@ interactive POSIX shell targeted at resource-constrained systems.")
(install-file "mksh" bin)
(with-directory-excursion bin
(symlink "mksh" "ksh"))
- (install-file "mksh.1" man)
- #t))))))
+ (install-file "mksh.1" man)))))))
(home-page "https://www.mirbsd.org/mksh.htm")
(synopsis "Korn Shell from MirBSD")
(description "mksh is an actively developed free implementation of the
@@ -842,14 +841,14 @@ Shell (pdksh).")
(define-public oil
(package
(name "oil")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "0mqf2wmc1p6xr2l54pxv97d0s23wqm1mwwgyzn06aafr93dy3vkg"))))
+ (base32 "1js5i25wgvz7avsrfygxy96axanc97yvlc69arp0ja9vkcrxv5px"))))
(build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f ; strip breaks the binary