summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-09-20 03:28:02 +0000
committerEfraim Flashner <efraim@flashner.co.il>2020-09-20 23:42:52 +0300
commit02406d5c51a8c38136ff8036dd1e62865b8714d1 (patch)
treed49d0ad9f3f8a912e2fbe878db0498f088f95440 /gnu/packages/shells.scm
parentfd5cace4c99a26ec51bf3a47d8af672f0ac2d4eb (diff)
downloadguix-patches-02406d5c51a8c38136ff8036dd1e62865b8714d1.tar
guix-patches-02406d5c51a8c38136ff8036dd1e62865b8714d1.tar.gz
gnu: oil: Update to 0.8.0.
* gnu/packages/shells.scm (oil): Update to 0.8.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 7868dc40f0..affc98a6e6 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -813,15 +813,14 @@ Shell (pdksh).")
(define-public oil
(package
(name "oil")
- ;; https://www.oilshell.org/blog/2020/04/release-0.8.pre4.html#comment-on-version-numbering
- (version "0.8.pre6")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "11nfwn5b1w74hv78065jg2zm45mqzi59381b0f649j7n3g7yp3iq"))))
+ (base32 "1455hy61prznzp05vigh96ypyz9zarhvvzmmxvf8cnpa39s39a8c"))))
(build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f ; strip breaks the binary
@@ -838,7 +837,7 @@ Shell (pdksh).")
(replace 'check
;; The tests are not distributed in the tarballs but upstream
;; recommends running this smoke test.
- ;; https://github.com/oilshell/oil/blob/release/0.8.pre6/INSTALL.txt#L38-L48
+ ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
(lambda _
(let* ((oil "_bin/oil.ovm"))
(invoke/quiet oil "osh" "-c" "echo hi")