summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 12:57:42 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 13:23:26 -0500
commit008649604296307682955d4c0da2525b606b7134 (patch)
tree95b672f38aa91eaf5fc3afecb1ae8aa61d7a6996 /gnu/packages/shells.scm
parent66707558b61c69edb3b3ee7dbec28a75acf75cd3 (diff)
downloadguix-patches-008649604296307682955d4c0da2525b606b7134.tar
guix-patches-008649604296307682955d4c0da2525b606b7134.tar.gz
gnu: tcsh: Incorporate grafted patch.
* gnu/packages/shells.scm (tcsh)[replacement]: Remove field. [source]: Add patch 'tcsh-fix-out-of-bounds-read.patch'. (tcsh/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 4ed1f4696b..d4a7d8090f 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -217,7 +217,6 @@ written by Paul Haahr and Byron Rakitzis.")
(define-public tcsh
(package
(name "tcsh")
- (replacement tcsh/fixed)
(version "6.18.01")
(source (origin
(method url-fetch)
@@ -230,7 +229,8 @@ written by Paul Haahr and Byron Rakitzis.")
(base32
"1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
(patches (search-patches "tcsh-fix-autotest.patch"
- "tcsh-do-not-define-BSDWAIT.patch"))
+ "tcsh-do-not-define-BSDWAIT.patch"
+ "tcsh-fix-out-of-bounds-read.patch"))
(patch-flags '("-p0"))))
(build-system gnu-build-system)
(inputs
@@ -275,15 +275,6 @@ command-line editor, programmable word completion, spelling correction, a
history mechanism, job control and a C-like syntax.")
(license bsd-4)))
-(define tcsh/fixed
- (package
- (inherit tcsh)
- (name "tcsh")
- (source (origin
- (inherit (package-source tcsh))
- (patches (cons (search-patch "tcsh-fix-out-of-bounds-read.patch")
- (origin-patches (package-source tcsh))))))))
-
(define-public zsh
(package
(name "zsh")