summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-06 06:58:24 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-06 06:59:12 +0000
commit03f99e14ed299c9e6fec54af6d1f4951ca3ff4f8 (patch)
tree240db0c7d3f8294807fa7b5b1236b8a8eabf927c /gnu/packages/serialization.scm
parent79fbbe5e4a7cd79613d49c0dda51872f2492cc76 (diff)
downloadguix-patches-03f99e14ed299c9e6fec54af6d1f4951ca3ff4f8.tar
guix-patches-03f99e14ed299c9e6fec54af6d1f4951ca3ff4f8.tar.gz
gnu: Add jsoncpp-with-pkg-version.
* gnu/packages/patches/jsoncpp-pkg-config-version: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/serialization.scm (jsoncpp-with-pkg-version): New variable.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index c8dcf65905..ae2e113483 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -454,6 +454,25 @@ preserve existing comment in unserialization/serialization steps, making
it a convenient format to store user input files.")
(license license:expat)))
+;; XXX: TODO(core-updates): Remove this package and apply the patch to the
+;; jsoncpp package. This patch fixes the package version declared in the
+;; pkg-config file.
+(define-public jsoncpp-with-pkg-version
+ (package
+ (inherit jsoncpp)
+ (name "jsoncpp")
+ (version "1.9.4")
+ (home-page "https://github.com/open-source-parsers/jsoncpp")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))
+ (patches
+ (search-patches "jsoncpp-pkg-config-version.patch"))))))
+
;; Tensorflow does not build with jsoncpp 1.8.x. It is built with commit
;; 4356d9bba191e1e16ce7a92073cbf3e63564e973, which lies between version 1.7.2
;; and 1.7.3.