summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 13:11:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 14:10:18 +0100
commit0300085cc984236c9557d16badbe9e6e46633ef3 (patch)
tree0166e6077d4473823c13bb9ea15d8bd2adfad236 /gnu/packages/serialization.scm
parente1e00e87e6e625d255477d5ec61e70bb70290189 (diff)
downloadguix-patches-0300085cc984236c9557d16badbe9e6e46633ef3.tar
guix-patches-0300085cc984236c9557d16badbe9e6e46633ef3.tar.gz
gnu: cereal: Don't use unstable tarball.
* gnu/packages/serialization.scm (cereal)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index ea016bc6c2..249b6f1af5 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -53,14 +53,15 @@
(package
(name "cereal")
(version "1.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/USCiLab/cereal/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0kj32h3j2128anig0g9gzw82kfyd5xqfkwq6vdyv900jx8i1qckx"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/USCiLab/cereal.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vxkrsnxkiblzi1z61vfix167c184fy868sgwj2dxxgbgjcq2nrh"))))
(build-system cmake-build-system)
(arguments
`(;; The only included tests are portability tests requiring