summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorHiPhish <hiphish@posteo.de>2018-10-24 14:22:14 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-26 21:17:00 +0200
commit01a0a0c445d42eda74e344d29a82e56f139aab31 (patch)
tree7ffa3d48bc5f2e8ccbbfb03db075759fcf58e608 /gnu/packages/serialization.scm
parent3239dcd38d28d6a34338a9c1a1ddad42a326f7a2 (diff)
downloadguix-patches-01a0a0c445d42eda74e344d29a82e56f139aab31.tar
guix-patches-01a0a0c445d42eda74e344d29a82e56f139aab31.tar.gz
gnu: Add lua5.1-lpeg and lua5.1-lmpack.
* gnu/packages/lua.scm (lua5.1-lpeg): New variable. * gnu/packages/serialization.scm (lua5.1-libmpack): New variable. The packages lua-lpeg and lua-libmpack had no Lua 5.1 variants. These packages will be needed to build Neovim properly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3064e385e2..6b28463d51 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -225,6 +225,26 @@ that implements both the msgpack and msgpack-rpc specifications.")
(home-page "https://github.com/libmpack/libmpack-lua")
(synopsis "Lua bindings for the libmpack binary serialization library")))
+(define-public lua5.1-libmpack
+ (package (inherit lua-libmpack)
+ (name "lua5.1-libmpack")
+ (arguments
+ (substitute-keyword-arguments (package-arguments lua-libmpack)
+ ((#:make-flags flags)
+ `(let* ((lua-version ,(package-version lua-5.1))
+ (lua-major+minor ,(version-major+minor (package-version lua-5.1))))
+ (list "CC=gcc"
+ "USE_SYSTEM_LUA=yes"
+ (string-append "MPACK_LUA_VERSION=" lua-version)
+ (string-append "MPACK_LUA_VERSION_NOPATCH=" lua-major+minor)
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "LUA_CMOD_INSTALLDIR="
+ (assoc-ref %outputs "out")
+ "/lib/lua/" lua-major+minor))))))
+ (inputs
+ `(("lua" ,lua-5.1)))))
+
(define-public lua5.2-libmpack
(package (inherit lua-libmpack)
(name "lua5.2-libmpack")