summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 21:29:46 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 21:29:46 +0200
commitf03426420497cd9839f5fb3cb547dbecd8d6053b (patch)
tree220cdbab5b58b27c63d2df3ee711ad4bfdda074b /gnu/packages/sequoia.scm
parent3cf1afb7e7249992b2db2f4f00899fd22237e89a (diff)
parent069399ee9dbf75b7c89583f03346a63b2cfe4ac6 (diff)
downloadguix-patches-f03426420497cd9839f5fb3cb547dbecd8d6053b.tar
guix-patches-f03426420497cd9839f5fb3cb547dbecd8d6053b.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/django.scm gnu/packages/gtk.scm gnu/packages/llvm.scm gnu/packages/python-web.scm gnu/packages/python.scm gnu/packages/tex.scm guix/build-system/asdf.scm guix/build/emacs-build-system.scm guix/profiles.scm
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index eb8a788449..90f107e9e7 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2019, 2020, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -42,15 +42,15 @@
(define-public sequoia
(package
(name "sequoia")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit (string-append "v" version))))
+ (commit (string-append "openpgp/v" version))))
(sha256
- (base32 "0y80bl786m29ww3272qsl1ql0xc3pwd6iiqlkv3nmhnjsmygbn0d"))
+ (base32 "0knkm0nw1h4ww51vks4jnnp1yc45llfi7j0i70f6vf2bcknnbmci"))
(file-name (git-file-name name version))))
(build-system cargo-build-system)
(outputs '("out" "python"))
@@ -140,12 +140,25 @@
;; Run make instead of using the rust build system, as
;; suggested by the installation instructions
(replace 'build (lambda _ (invoke "make" "build-release") #t))
+ (delete 'package) ;; cargo can't package a multi-crate workspace
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
(invoke "make" "check")
#t)))
(replace 'install (lambda _ (invoke "make" "install") #t))
+ (add-after 'unpack 'fix-rand-dependency
+ (lambda _
+ (substitute* "ipc/Cargo.toml"
+ ;; required: enable rand::rngs::OsRng in rand >= 0.8
+ (("(^rand =.*,) default-features = false(.*)" _ a b)
+ (string-append a " features = [\"getrandom\"]" b)))
+ #t))
+ (add-after 'unpack 'fix-permissions
+ (lambda _
+ (chmod "sq/src/sq-usage.rs" #o644)
+ (chmod "sqv/src/sqv-usage.rs" #o644)
+ #t))
(add-after 'unpack 'fix-environment
(lambda* (#:key outputs #:allow-other-keys)
;; adjust prefix