summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-18 21:12:46 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-30 21:32:45 +0100
commitbf7ed7c9f2083e5bf81fffa41e2e7213817d5acd (patch)
tree64b1eb0828f8133d0096404c20e0d1a8b5371496 /gnu/packages/sequoia.scm
parenta3765072d29ffe5a693cd05068bf448c646a79cb (diff)
downloadguix-patches-bf7ed7c9f2083e5bf81fffa41e2e7213817d5acd.tar
guix-patches-bf7ed7c9f2083e5bf81fffa41e2e7213817d5acd.tar.gz
gnu: rust-sequoia-rfc2822-0.9: Move to (gnu packages sequoia).
* gnu/packages/crates-io.scm (rust-sequoia-rfc2822-0.9): Move package to ... * gnu/packages/sequoia.scm: ... here. [arguments]<skip-build?> Add. <cargo-development-inputs>: Remove. [description] Reformat and add markup.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 1d9260249c..a8d21ac1a4 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -281,6 +281,34 @@ This Guix package is built to use the nettle cryptographic library.")
("rust-sequoia-rfc2822" ,rust-sequoia-rfc2822-0.9)
("rust-time" ,rust-time-0.1))))))
+(define-public rust-sequoia-rfc2822-0.9
+ (package
+ (name "rust-sequoia-rfc2822")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sequoia-rfc2822" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1aj34i6862718m162rqfv69fkmvdw063s6ws7hbp42n73gb08p5c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-failure" ,rust-failure-0.1)
+ ("rust-lalrpop" ,rust-lalrpop-0.17)
+ ("rust-lalrpop-util" ,rust-lalrpop-util-0.17))))
+ (home-page "https://sequoia-pgp.org/")
+ (synopsis "RFC 2822 name-addr parser")
+ (description "Currently, this crate only recognizes the RFC 2822 name-addr
+and addr-spec productions, i.e., things of the form: @code{Name (Comment)
+<email@@example.org>} and @code{email@@example.org}
+
+Although the above appear simple to parse, RFC 2822's whitespace and comment
+rules are rather complex. This crate implements the whole grammar." )
+ (license license:gpl3)))
+
(define-public sequoia-sq
(package
(name "sequoia-sq")