summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-16 20:13:42 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-08 10:33:12 +0100
commita240686cc34454a3221c31f3c546985c2c90bf2c (patch)
tree5307e6b86eea82f9aaf3e9dc45cad8d79e857648 /gnu/packages/sequoia.scm
parente0158630d3355d27fc29bb2aba36967f5a313b95 (diff)
downloadguix-patches-a240686cc34454a3221c31f3c546985c2c90bf2c.tar
guix-patches-a240686cc34454a3221c31f3c546985c2c90bf2c.tar.gz
gnu: sequoia: Update to 1.0.0.
* gnu/packages/sequoia.scm (sequoia): Update to 1.0.0. [arguments]{cargo-inputs}: Add rust-eax, rust-futures-util, rust-sha1collisiondetection, rust-socket2. Update rust-capnp, rust-capnp-rpc, rust-capnpc, rust-futures, rust-http,rust-hyper rust-hyper-tls, rust-tokio, rust-win-crypto-ng.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index f07416c315..ce3396a7c4 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -40,7 +40,7 @@
(define-public sequoia
(package
(name "sequoia")
- (version "0.20.0")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
@@ -48,7 +48,7 @@
(url "https://gitlab.com/sequoia-pgp/sequoia.git")
(commit (string-append "v" version))))
(sha256
- (base32 "1c76sz4y0n4jhf1gq4b87v5c07i09mmd3i6sqki09bd96m3ldgkf"))
+ (base32 "0y80bl786m29ww3272qsl1ql0xc3pwd6iiqlkv3nmhnjsmygbn0d"))
(file-name (git-file-name name version))))
(build-system cargo-build-system)
(outputs '("out" "python"))
@@ -75,9 +75,9 @@
("rust-base64" ,rust-base64-0.13)
;;("rust-buffered-reader" included
("rust-bzip2" ,rust-bzip2-0.4)
- ("rust-capnp" ,rust-capnp-0.10)
- ("rust-capnp-rpc" ,rust-capnp-rpc-0.10)
- ("rust-capnpc" ,rust-capnpc-0.10)
+ ("rust-capnp" ,rust-capnp-0.13)
+ ("rust-capnp-rpc" ,rust-capnp-rpc-0.13)
+ ("rust-capnpc" ,rust-capnpc-0.13)
("rust-chrono" ,rust-chrono-0.4) ;; for sqv, sop
("rust-clap" ,rust-clap-2) ;; for sqv
("rust-colored" ,rust-colored-1.9.1)
@@ -86,14 +86,16 @@
("rust-dirs" ,rust-dirs-2.0)
("rust-dyn-clone" ,rust-dyn-clone-1)
("rust-ed25519-dalek" ,rust-ed25519-dalek-1)
+ ("rust-eax" ,rust-eax-0.3)
;;("rust-failure" included
("rust-filetime" ,rust-filetime-0.2)
("rust-flate2" ,rust-flate2-1)
("rust-fs2" ,rust-fs2-0.4)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-http" ,rust-http-0.1)
- ("rust-hyper" ,rust-hyper-0.12)
- ("rust-hyper-tls" ,rust-hyper-tls-0.3)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-hyper" ,rust-hyper-0.13)
+ ("rust-hyper-tls" ,rust-hyper-tls-0.4)
("rust-idna" ,rust-idna-0.2)
("rust-itertools" ,rust-itertools-0.9) ;; for sq
("rust-lalrpop" ,rust-lalrpop-0.19)
@@ -112,14 +114,16 @@
("rust-rand" ,rust-rand-0.7)
("rust-regex" ,rust-regex-1)
("rust-rusqlite" ,rust-rusqlite-0.24)
+ ("rust-sha1collisiondetection" ,rust-sha1collisiondetection-0.2)
+ ("rust-socket2", rust-socket2-0.3)
("rust-structopt" ,rust-structopt-0.3) ;; for sop
("rust-tempfile" ,rust-tempfile-3) ;; for sq
("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-0.1)
+ ("rust-tokio" ,rust-tokio-0.2)
("rust-tokio-core" ,rust-tokio-core-0.1)
("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
("rust-url" ,rust-url-2)
- ("rust-win-crypto-ng" ,rust-win-crypto-ng-0.2)
+ ("rust-win-crypto-ng" ,rust-win-crypto-ng-0.4)
("rust-winapi" ,rust-winapi-0.3)
("rust-zbase32" ,rust-zbase32-0.1))
#:cargo-development-inputs