summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-07 12:08:10 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-30 21:32:43 +0100
commit8efe6f00c816f6aac40760ea428da1119183263a (patch)
treea6d6e05979c037a6b6c854698953f7073a1cf981 /gnu/packages/sequoia.scm
parentb0b881e02f2db159e8ef4798b2c72c20ccbe2e9d (diff)
downloadguix-patches-8efe6f00c816f6aac40760ea428da1119183263a.tar
guix-patches-8efe6f00c816f6aac40760ea428da1119183263a.tar.gz
gnu: Add rust-sequoia-autocrypt-0.23.
* gnu/packages/sequoia.scm (rust-sequoia-autocrypt-0.23): New variable.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index c01fedc56f..b18d3cbec6 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -39,6 +39,37 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls))
+(define-public rust-sequoia-autocrypt-0.23
+ (package
+ (name "rust-sequoia-autocrypt")
+ (version "0.23.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sequoia-autocrypt" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0skj0dv15341v470g6w5pggsl0iy27qb8h24rr8k6rq7vxdjxl7g"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-base64" ,rust-base64-0.13)
+ ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-other-crypto-features
+ (lambda _
+ (substitute* "Cargo.toml"
+ (("^crypto-cng =" line) (string-append "# " line))
+ (("^crypto-rust =" line) (string-append "# " line))))))))
+ (home-page "https://sequoia-pgp.org/")
+ (synopsis "Deal with Autocrypt encoded data")
+ (description "This crate implements low-level functionality like encoding
+and decoding of Autocrypt headers and setup messages. Note: Autocrypt is more
+than just headers; it requires tight integration with the MUA.")
+ (license license:lgpl2.0+)))
+
(define-public rust-sequoia-ipc-0.26
(package
(name "rust-sequoia-ipc")