summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/sequoia.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 719a9d2ef4..3757fdd971 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -55,19 +55,16 @@
(build-system cargo-build-system)
(outputs '("out" "python"))
(native-inputs
- `(("clang" ,clang)
- ("pkg-config" ,pkg-config)
- ("python-pytest" ,python-pytest)
- ("python-pytest-runner" ,python-pytest-runner)
- ("python-wrapper" ,python-wrapper)))
+ (list clang pkg-config python-pytest python-pytest-runner
+ python-wrapper))
(inputs
- `(("capnproto" ,capnproto)
- ("gmp" ,gmp)
- ("nettle" ,nettle)
- ("openssl" ,openssl)
- ("python" ,python)
- ("python-cffi" ,python-cffi)
- ("sqlite" ,sqlite)))
+ (list capnproto
+ gmp
+ nettle
+ openssl
+ python
+ python-cffi
+ sqlite))
(arguments
`(#:tests? #f ;; building the tests requires 9.7GB total
#:rust ,rust