summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 14:13:10 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:35 +0200
commite015fc174e13759aa9c96dc19bf534efd1be7d72 (patch)
treee8a218004abf11b015d61372970b78fd76885d1f /gnu/packages/selinux.scm
parentd7278e4020cb3197d6f4d18e3347137e5f710774 (diff)
downloadguix-patches-e015fc174e13759aa9c96dc19bf534efd1be7d72.tar
guix-patches-e015fc174e13759aa9c96dc19bf534efd1be7d72.tar.gz
gnu: policycoreutils: Use G-expression.
* gnu/packages/selinux.scm (policycoreutils)[arguments]: Convert to gexp.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm75
1 files changed, 38 insertions, 37 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index e4c57f4747..b4f074b695 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -354,43 +354,44 @@ tools, and libraries designed to facilitate SELinux policy analysis.")
(package/inherit libsepol
(name "policycoreutils")
(arguments
- `(#:test-target "test"
- #:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" out)
- (string-append "LOCALEDIR=" out "/share/locale")
- (string-append "BASHCOMPLETIONDIR=" out
- "/share/bash-completion/completions")
- "INSTALL=install -c -p"
- "INSTALL_DIR=install -d"
- ;; These ones are needed because some Makefiles define the
- ;; directories relative to DESTDIR, not relative to PREFIX.
- (string-append "SBINDIR=" out "/sbin")
- (string-append "ETCDIR=" out "/etc")
- (string-append "SYSCONFDIR=" out "/etc/sysconfig")
- (string-append "MAN5DIR=" out "/share/man/man5")
- (string-append "INSTALL_NLS_DIR=" out "/share/locale")
- (string-append "AUTOSTARTDIR=" out "/etc/xdg/autostart")
- (string-append "DBUSSERVICEDIR=" out "/share/dbus-1/services")
- (string-append "SYSTEMDDIR=" out "/lib/systemd")
- (string-append "INITDIR=" out "/etc/rc.d/init.d")
- (string-append "SELINUXDIR=" out "/etc/selinux")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'enter-dir
- (lambda _ (chdir ,name)))
- (add-after 'enter-dir 'ignore-/usr-tests
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Rewrite lookup paths for header files.
- (substitute* '("newrole/Makefile"
- "setfiles/Makefile"
- "run_init/Makefile")
- (("/usr(/include/security/pam_appl.h)" _ file)
- (search-input-file inputs file))
- (("/usr(/include/libaudit.h)" _ file)
- (search-input-file inputs file))))))))
+ (list
+ #:test-target "test"
+ #:make-flags
+ #~(let ((out #$output))
+ (list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" out)
+ (string-append "LOCALEDIR=" out "/share/locale")
+ (string-append "BASHCOMPLETIONDIR=" out
+ "/share/bash-completion/completions")
+ "INSTALL=install -c -p"
+ "INSTALL_DIR=install -d"
+ ;; These ones are needed because some Makefiles define the
+ ;; directories relative to DESTDIR, not relative to PREFIX.
+ (string-append "SBINDIR=" out "/sbin")
+ (string-append "ETCDIR=" out "/etc")
+ (string-append "SYSCONFDIR=" out "/etc/sysconfig")
+ (string-append "MAN5DIR=" out "/share/man/man5")
+ (string-append "INSTALL_NLS_DIR=" out "/share/locale")
+ (string-append "AUTOSTARTDIR=" out "/etc/xdg/autostart")
+ (string-append "DBUSSERVICEDIR=" out "/share/dbus-1/services")
+ (string-append "SYSTEMDDIR=" out "/lib/systemd")
+ (string-append "INITDIR=" out "/etc/rc.d/init.d")
+ (string-append "SELINUXDIR=" out "/etc/selinux")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'enter-dir
+ (lambda _ (chdir #$name)))
+ (add-after 'enter-dir 'ignore-/usr-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Rewrite lookup paths for header files.
+ (substitute* '("newrole/Makefile"
+ "setfiles/Makefile"
+ "run_init/Makefile")
+ (("/usr(/include/security/pam_appl.h)" _ file)
+ (search-input-file inputs file))
+ (("/usr(/include/libaudit.h)" _ file)
+ (search-input-file inputs file))))))))
(inputs
(list audit
linux-pam