summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-15 02:47:00 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-15 02:47:45 -0400
commit9ffc1f0e95743171370e3999bd41eba9ebaada33 (patch)
tree1849c44864e4591bfcb822dc6eb1373d3d7bac9b /gnu/packages/selinux.scm
parent4dbef2397f05493e1d59f3112cda94729f5968b5 (diff)
downloadguix-patches-9ffc1f0e95743171370e3999bd41eba9ebaada33.tar
guix-patches-9ffc1f0e95743171370e3999bd41eba9ebaada33.tar.gz
gnu: libselinux: Propagate libsepol and pcre.
Both libsepol and pcre required by libselinux.pc. * gnu/packages/selinux.scm (libselinux)[inputs]: Move libsepol and pcre... [propagated-inputs]: ...here.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 81c899f841..729ae646b2 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -157,11 +157,13 @@ module into a binary representation.")
(add-after 'install 'install-pywrap
(lambda* (#:key make-flags #:allow-other-keys)
(zero? (apply system* "make" "install-pywrap" make-flags))))))))
- (inputs
+ ;; These libraries are in "Requires.private" in libselinux.pc.
+ (propagated-inputs
`(("libsepol" ,libsepol)
- ("pcre" ,pcre)
- ;; For pywrap phase
- ("python" ,python-wrapper)))
+ ("pcre" ,pcre)))
+ ;; For pywrap phase
+ (inputs
+ `(("python" ,python-wrapper)))
;; These inputs are only needed for the pywrap phase.
(native-inputs
`(("swig" ,swig)