summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 13:46:01 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:35 +0200
commit9bfdd1e7cb4596e3aee68c21a4ad39e0540a8c3a (patch)
treefb631ddf032e834c35195392526c3887487fc329 /gnu/packages/selinux.scm
parent54f14833a93eab22d0c4f95e3fc38106e150f3d0 (diff)
downloadguix-patches-9bfdd1e7cb4596e3aee68c21a4ad39e0540a8c3a.tar
guix-patches-9bfdd1e7cb4596e3aee68c21a4ad39e0540a8c3a.tar.gz
gnu: libsemanage: Remove input labels.
* gnu/packages/selinux.scm (libsemanage)[arguments]: Use G-expression. [native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm56
1 files changed, 24 insertions, 32 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 93c256371a..3e7d55ff67 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -187,41 +187,33 @@ the core SELinux management utilities.")
(arguments
(substitute-keyword-arguments (package-arguments libsepol)
((#:make-flags flags)
- `(cons* "PYTHON=python3"
- (string-append "PYTHONLIBDIR="
- (assoc-ref %outputs "out")
- "/lib/python"
- ,(version-major+minor (package-version python))
- "/site-packages/")
- ,flags))
+ #~(cons* "PYTHON=python3"
+ (string-append "PYTHONLIBDIR="
+ #$output
+ "/lib/python"
+ #$(version-major+minor (package-version python))
+ "/site-packages/")
+ #$flags))
((#:phases phases)
- `(modify-phases ,phases
- (delete 'portability)
- (replace 'enter-dir
- (lambda _ (chdir ,name)))
- (add-before 'install 'adjust-semanage-conf-location
- (lambda _
- (substitute* "src/Makefile"
- (("DEFAULT_SEMANAGE_CONF_LOCATION=/etc")
- "DEFAULT_SEMANAGE_CONF_LOCATION=$(PREFIX)/etc"))))
- (add-after 'build 'pywrap
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "pywrap" make-flags)))
- (add-after 'install 'install-pywrap
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "install-pywrap" make-flags)))))))
+ #~(modify-phases #$phases
+ (delete 'portability)
+ (replace 'enter-dir
+ (lambda _ (chdir #$name)))
+ (add-before 'install 'adjust-semanage-conf-location
+ (lambda _
+ (substitute* "src/Makefile"
+ (("DEFAULT_SEMANAGE_CONF_LOCATION=/etc")
+ "DEFAULT_SEMANAGE_CONF_LOCATION=$(PREFIX)/etc"))))
+ (add-after 'build 'pywrap
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "pywrap" make-flags)))
+ (add-after 'install 'install-pywrap
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install-pywrap" make-flags)))))))
(inputs
- `(("libsepol" ,libsepol)
- ("libselinux" ,libselinux)
- ("audit" ,audit)
- ;; For pywrap phase
- ("python" ,python-wrapper)))
+ (list audit libsepol libselinux python-wrapper))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ;; For pywrap phase
- ("swig" ,swig)
- ("pkg-config" ,pkg-config)))
+ (list bison flex pkg-config swig))
(synopsis "SELinux policy management libraries")
(description
"The libsemanage library provides an API for the manipulation of SELinux