summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-25 04:52:02 -0400
committerMark H Weaver <mhw@netris.org>2018-03-25 05:02:07 -0400
commit927c52c4ab148e83861e48bb07b08588a386043b (patch)
treeef6e431d19793d6f2c67d59c8d7547e66c49fe35 /gnu/packages/selinux.scm
parentd5c88f16c45ed9e9404a30d1dc8b4183aee9e6bb (diff)
downloadguix-patches-927c52c4ab148e83861e48bb07b08588a386043b.tar
guix-patches-927c52c4ab148e83861e48bb07b08588a386043b.tar.gz
gnu: libselinux: Use invoke.
* gnu/packages/selinux.scm (libselinux)[arguments]: Use invoke in the 'pywrap' and 'install-pywrap' phases.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 3db1b458c7..9562123bda 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -157,10 +157,10 @@ module into a binary representation.")
#t))
(add-after 'build 'pywrap
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "pywrap" make-flags))))
+ (apply invoke "make" "pywrap" make-flags)))
(add-after 'install 'install-pywrap
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-pywrap" make-flags))))))))
+ (apply invoke "make" "install-pywrap" make-flags)))))))
;; These libraries are in "Requires.private" in libselinux.pc.
(propagated-inputs
`(("libsepol" ,libsepol)