summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-11 15:40:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-11 15:40:20 +0200
commit568d060327291dd3fcb0e20c3b5c493047ae6902 (patch)
treed18ae7c4a7f6e05d13c80e1f9082f17e6cfb7edd /gnu/packages/selinux.scm
parentff1e80d7918df85b78216a70ab31062af320c0e4 (diff)
downloadguix-patches-568d060327291dd3fcb0e20c3b5c493047ae6902.tar
guix-patches-568d060327291dd3fcb0e20c3b5c493047ae6902.tar.gz
gnu: libselinux: Install python bindings to separate output.
This reduces the closure size of glib from 203.1 to 111.3 MiB. * gnu/packages/selinux.scm (libselinux)[outputs]: New field. [arguments]: Set PYSITEDIR to the new "python" output.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index e540a140a1..1c45cb8c7e 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -131,6 +131,7 @@ module into a binary representation.")
(define-public libselinux
(package (inherit libsepol)
(name "libselinux")
+ (outputs '("out" "python"))
(arguments
(substitute-keyword-arguments (package-arguments libsepol)
((#:make-flags flags)
@@ -139,7 +140,7 @@ module into a binary representation.")
(assoc-ref %build-inputs "libsepol")
"/lib/libsepol.a")
(string-append "PYSITEDIR="
- (assoc-ref %outputs "out")
+ (assoc-ref %outputs "python")
"/lib/python"
,(version-major+minor (package-version python))
"/site-packages/")