summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 13:33:19 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:34 +0200
commit0d79288fb6d8b27b235693374c6eaea4cdd38c80 (patch)
tree85e868d69826f07649435c3af9b782e78664e098 /gnu/packages/selinux.scm
parentca6078e1e92ee19341bfdcedcc2fde630fbcd3bb (diff)
downloadguix-patches-0d79288fb6d8b27b235693374c6eaea4cdd38c80.tar
guix-patches-0d79288fb6d8b27b235693374c6eaea4cdd38c80.tar.gz
gnu: SELinux: Update to 3.4.
* gnu/packages/selinux.scm (libsepol): Update to 3.4. (libselinux)[propagated-inputs]: Replace PCRE with PCRE2.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 0000bc7bc9..fd1c79a9ab 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
@@ -49,7 +49,7 @@
(define-public libsepol
(package
(name "libsepol")
- (version "3.2")
+ (version "3.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -58,7 +58,7 @@
(file-name (git-file-name "selinux" version))
(sha256
(base32
- "03p3lmvrvkcvsmiczsjzhyfgxlxdkdyq0p8igv3s3hdak5n92jjn"))))
+ "1lcmgmfr0q7g5cwg6b7jm6ncw8cw6c1jblkm93v1g37bfhcgrqc0"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; tests require checkpolicy, which requires libsepol
@@ -161,12 +161,11 @@ module into a binary representation.")
(substitute* "src/Makefile"
(("--prefix=\\$\\(PREFIX\\)")
(string-append "--prefix=" (assoc-ref outputs "python"))))
-
(apply invoke "make" "install-pywrap" make-flags)))))))
;; These libraries are in "Requires.private" in libselinux.pc.
(propagated-inputs
`(("libsepol" ,libsepol)
- ("pcre" ,pcre)))
+ ("pcre2" ,pcre2)))
;; For pywrap phase
(inputs
`(("python" ,python-wrapper)))