summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-04-26 20:37:10 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-10-10 10:23:23 +0200
commite84eb77a3aa06ef6f3bc952170df54f52e1bfcfc (patch)
tree1c252962cc7a44569aa05499f629d8536eaf5e5f /gnu/packages/security-token.scm
parent167a541fd8439eed50294a94890a8ae5c5ec448c (diff)
downloadguix-patches-e84eb77a3aa06ef6f3bc952170df54f52e1bfcfc.tar
guix-patches-e84eb77a3aa06ef6f3bc952170df54f52e1bfcfc.tar.gz
gnu: Add eid-mw.
* gnu/packages/security-token.scm (eid-mw): New variable.
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm53
1 files changed, 52 insertions, 1 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 8ae2dda1c3..c6e3d6b355 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,12 +26,20 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
+ #:use-module (gnu packages networking)
+ #:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml))
(define-public ccid
(package
@@ -70,6 +79,48 @@ readers and is needed to communicate with such devices through the
@command{pcscd} resource manager.")
(license license:lgpl2.1+)))
+(define-public eid-mw
+ (package
+ (name "eid-mw")
+ (version "4.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Fedict/eid-mw/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0s646p19kq27wb160v9b8aaiy30k2shmq4njm471ggd2j7n7a6rs"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (inputs
+ `(("curl" ,curl)
+ ("openssl" ,openssl)
+ ("gtk+" ,gtk+)
+ ("pcsc-lite" ,pcsc-lite)
+ ("p11-kit" ,p11-kit)
+ ("libproxy" ,libproxy)
+ ("libxml2" ,libxml2)
+ ("cyrus-sasl" ,cyrus-sasl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The github tarball doesn't contain a configure script.
+ (add-before 'configure 'autoreconf
+ (lambda _ (zero? (system* "autoreconf" "-i")))))))
+ (synopsis "Belgian eID Middleware")
+ (description "The Belgian eID Middleware is required to authenticate with
+online services using the Belgian electronic identity card.")
+ (home-page "https://github.com/Fedict/eid-mw")
+ (license license:lgpl3)))
+
(define-public libyubikey
(package
(name "libyubikey")