summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2020-11-06 20:16:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 17:48:03 +0100
commite6e31a59eb3d400bc264b0f70a1631cf5a8ae9c9 (patch)
tree8a6c812399a7c93ed2e382ba6d9dfc0d6311fef6 /gnu/packages/security-token.scm
parentd2bf896155851fee524b045a790b949ea6863c76 (diff)
downloadguix-patches-e6e31a59eb3d400bc264b0f70a1631cf5a8ae9c9.tar
guix-patches-e6e31a59eb3d400bc264b0f70a1631cf5a8ae9c9.tar.gz
gnu: eid-mw: Update to 5.0.8.
* gnu/packages/security-token.scm (eid-mw): Update to 5.0.8. [arguments]: Add a ‘remove-failing-test’ phase. [inputs]: Add autoconf-archive and libassuan. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 162868ad7a..09222b571a 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2020 Raphaël Mélotte <raphael.melotte@mind.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages gettext)
#:use-module (gnu packages graphviz)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -102,7 +104,7 @@ readers and is needed to communicate with such devices through the
(define-public eid-mw
(package
(name "eid-mw")
- (version "4.4.27")
+ (version "5.0.8")
(source
(origin
(method git-fetch)
@@ -111,13 +113,15 @@ readers and is needed to communicate with such devices through the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "17lw8iwp7h5cs3db80sysr84ffi333cf2vrhncs9l6hy6glfl2v1"))))
+ (base32 "1ckini00iz9w96n9hpkx6w2ivpfkd4yyxyhnmsl9n0k8x4j6jg5a"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("gettext" ,gettext-minimal)
("libtool" ,libtool)
+ ("libassuan" ,libassuan)
("pkg-config" ,pkg-config)
("perl" ,perl)))
(inputs
@@ -145,7 +149,16 @@ readers and is needed to communicate with such devices through the
(substitute* "scripts/mac/create-vers.sh"
(("NOW=.*")
"NOW=1970-01-01\n"))
- #t)))))
+ #t))
+ ;; Remove failing test that was removed upstream after version 5.0.8.
+ ;; See: https://github.com/Fedict/eid-mw/commit/3d1187b1b61118b9ae97607903d3d2fc0bad7518
+ (add-before 'check 'remove-failing-test
+ (lambda _
+ (substitute* "tests/unit/Makefile.am"
+ (("sign_state ordering cardcom_common")
+ "sign_state ordering #cardcom_common"))
+ #t))
+ )))
(synopsis "Belgian eID Middleware")
(description "The Belgian eID Middleware is required to authenticate with
online services using the Belgian electronic identity card.")