summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-31 12:47:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 14:49:47 +0200
commitbc5155b952ae8bdbc56aded4d8d39768b4e2a7d4 (patch)
tree6b55475d86c522543384dea7d1ab66bba32af63e /gnu/packages/security-token.scm
parentdac8d013bd1fc7f57b8ba3582eef6e0e01b23dfd (diff)
parent4e5000114ec01b5e92a87c52f2a10f9ba7a601c8 (diff)
downloadguix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar
guix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm24
1 files changed, 6 insertions, 18 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 319cdee0ef..cc8840bb10 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
@@ -112,7 +113,8 @@ readers and is needed to communicate with such devices through the
(define-public eid-mw
(package
(name "eid-mw")
- (version "5.0.14")
+ ;; When updating, remove the short-lived libbsd input and module import!
+ (version "5.0.28")
(source
(origin
(method git-fetch)
@@ -121,7 +123,7 @@ readers and is needed to communicate with such devices through the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hyxsbxjjn9hh5p7jlcfb5yplf3n8dg49dfgi8fjp95phis3gbd4"))))
+ (base32 "0fmpdx09a60ndbsvy3m6w77naqy3j6k2ydq6jdcmdvxnr31z7fmf"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -134,6 +136,7 @@ readers and is needed to communicate with such devices through the
("perl" ,perl)))
(inputs
`(("curl" ,curl)
+ ("libbsd" ,libbsd)
("openssl" ,openssl)
("gtk+" ,gtk+)
("pcsc-lite" ,pcsc-lite)
@@ -153,22 +156,7 @@ readers and is needed to communicate with such devices through the
(substitute* "scripts/build-aux/genver.sh"
(("/bin/sh") (which "sh"))
(("^(GITDESC=).*" _ match) (string-append match ,version "\n")))
- (invoke "sh" "./bootstrap.sh")))
- (add-after 'unpack 'make-reproducible
- (lambda _
- (substitute* "scripts/mac/create-vers.sh"
- (("NOW=.*")
- "NOW=1970-01-01\n"))
- #t))
- ;; Remove failing test that was removed upstream after version 5.0.8.
- ;; See: https://github.com/Fedict/eid-mw/commit/3d1187b1b61118b9ae97607903d3d2fc0bad7518
- (add-before 'check 'remove-failing-test
- (lambda _
- (substitute* "tests/unit/Makefile.am"
- (("sign_state ordering cardcom_common")
- "sign_state ordering #cardcom_common"))
- #t))
- )))
+ (invoke "sh" "./bootstrap.sh"))))))
(synopsis "Belgian eID Middleware")
(description "The Belgian eID Middleware is required to authenticate with
online services using the Belgian electronic identity card.")