summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorMike Gerwitz <mtg@gnu.org>2016-10-22 12:04:24 -0400
committerMarius Bakke <mbakke@fastmail.com>2016-10-27 09:56:52 +0100
commita6b256affc94bce215003e52de50ed3fa6fc0106 (patch)
tree5f2523ff2c745e3c929b39148619e6790d1952a1 /gnu/packages/security-token.scm
parent8888fe826c44b760783c2a82f140ebcda67bb22d (diff)
downloadguix-patches-a6b256affc94bce215003e52de50ed3fa6fc0106.tar
guix-patches-a6b256affc94bce215003e52de50ed3fa6fc0106.tar.gz
gnu: Add pcsc-lite.
* gnu/packages/security-token.scm (pcsc-lite): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm38
1 files changed, 36 insertions, 2 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 36ccaa5203..735b2fe0ec 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,9 +24,11 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages man)
- #:use-module (gnu packages curl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config))
(define-public libyubikey
(package
@@ -47,6 +50,37 @@ the low-level development kit for the Yubico YubiKey authentication device.")
(home-page "https://developers.yubico.com/yubico-c/")
(license license:bsd-2)))
+(define-public pcsc-lite
+ (package
+ (name "pcsc-lite")
+ (version "1.8.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://alioth.debian.org/frs/download.php/file/4179/"
+ "pcsc-lite-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0189s10xsgcmdvc2sixakncwlv47cg6by6m9vdm038gn32q34bdj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-usbdropdir=/var/lib/pcsc/drivers")))
+ (native-inputs
+ `(("perl" ,perl) ; for pod2man
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libudev" ,eudev)))
+ (home-page "https://pcsclite.alioth.debian.org/pcsclite.html")
+ (synopsis "Middleware to access a smart card using PC/SC")
+ (description
+ "pcsc-lite provides an interface to communicate with smartcards and
+readers using the SCard API. pcsc-lite is used to connect to the PC/SC daemon
+from a client application and provide access to the desired reader.")
+ (license (list license:bsd-3 ; pcsc-lite
+ license:expat ; src/sd-daemon.[ch]
+ license:isc ; src/strlcat.c src/strlcpy.c
+ license:gpl3+)))) ; src/spy/*
+
(define-public ykclient
(package
(name "ykclient")