summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/security-token.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm50
1 files changed, 46 insertions, 4 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index cc8840bb10..537f43cb89 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Sergey Trofimov <sarg@sarg.org.ru>
;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
+;;; Copyright © 2021 Ahmad Jarara <git@ajarara.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages curl)
#:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -146,7 +148,12 @@ readers and is needed to communicate with such devices through the
("cyrus-sasl" ,cyrus-sasl)))
(arguments
`(#:configure-flags
- (list "--disable-static")
+ (list "--disable-static"
+
+ ;; With the (prettier) pinentry enabled, eid-viewer will skip
+ ;; crucial dialogue when used with card readers with built-in
+ ;; keypads such as the Digipass 870, and possibly others too.
+ "--disable-pinentry")
#:phases
(modify-phases %standard-phases
(replace 'bootstrap
@@ -157,9 +164,11 @@ readers and is needed to communicate with such devices through the
(("/bin/sh") (which "sh"))
(("^(GITDESC=).*" _ match) (string-append match ,version "\n")))
(invoke "sh" "./bootstrap.sh"))))))
- (synopsis "Belgian eID Middleware")
- (description "The Belgian eID Middleware is required to authenticate with
-online services using the Belgian electronic identity card.")
+ (synopsis "Belgian electronic identity card (eID) middleware")
+ (description "The Belgian eID middleware is required to authenticate with
+online services and sign digital documents with Belgian identity cards.
+
+It requires a running pcscd service and a compatible card reader.")
(home-page "https://github.com/Fedict/eid-mw")
(license license:lgpl3)))
@@ -778,3 +787,36 @@ used for online authentication with electronic German ID cards and residence
titles. To use this app, a supported RFID card reader or NFC-enabled smart
phone is required.")
(license license:eupl1.2)))
+
+(define-public libfido2
+ (package
+ (name "libfido2")
+ (version "1.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/Yubico/libfido2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "12zy4cnlcffcb64lsx8198y09j1dwi0bcn9rr82q6i1k950yzd3p"))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("udev" ,eudev)
+ ("libcbor" ,libcbor)
+ ("openssl" ,openssl)))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; regress tests enabled only for debug builds
+ (delete 'check))))
+ (synopsis "Library functionality and command-line tools for FIDO devices")
+ (description "libfido2 provides library functionality and command-line
+tools to communicate with a FIDO device over USB, and to verify attestation
+and assertion signatures.
+
+libfido2 supports the FIDO U2F (CTAP 1) and FIDO 2.0 (CTAP 2) protocols.")
+ (license license:bsd-2)
+ (home-page "https://github.com/Yubico/libfido2")))