summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-15 14:45:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-15 14:45:45 +0200
commit5799e5ae07a09d7d83ab64edb3a19e92243c9547 (patch)
treef95e3e7599f9a0c45c5b1e46f08ba08991d1c74d /gnu/packages/security-token.scm
parentfac39b99a5b02d21182ccd0e12e3bfc09ba34a8f (diff)
downloadguix-patches-5799e5ae07a09d7d83ab64edb3a19e92243c9547.tar
guix-patches-5799e5ae07a09d7d83ab64edb3a19e92243c9547.tar.gz
gnu: opensc: Update to 0.18.0.
* gnu/packages/security-token.scm (opensc): Update to 0.18.0. [arguments]: Add phase to disable test which fails in this release.
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 68cda50170..4369a8342d 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -219,7 +219,7 @@ website for more information about Yubico and the YubiKey.")
(define-public opensc
(package
(name "opensc")
- (version "0.17.0")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -227,7 +227,7 @@ website for more information about Yubico and the YubiKey.")
version "/opensc-" version ".tar.gz"))
(sha256
(base32
- "0043jh5g7q2lyd5vnb0akwb5y349isx7vbm9wqhlgav7d20wcwxy"))))
+ "0mrpik6ifzh27ws7h0viv8nwgcdj3fp5whaldmj0zhfi1l1zzh4v"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -244,7 +244,13 @@ website for more information about Yubico and the YubiKey.")
(("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
(string-append
"DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))
- #t))))))
+ #t)))
+ (add-before 'check 'disable-broken-test
+ (lambda _
+ ;; XXX: This test is fixed in git, remove this phase for >= 0.19.
+ (substitute* "doc/tools/Makefile"
+ (("TESTS = test-manpage.sh") "TESTS = "))
+ #t)))))
(inputs
`(("readline" ,readline)
("openssl" ,openssl)