summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 23:41:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 00:47:03 +0100
commit249deec95fbf291c50e8fda74cf83f8e0109bd0b (patch)
tree279859f2e0e6f53518b4d1fed1dc553c3ee898d7 /gnu/packages/security-token.scm
parent71a5da8e116fab0610e6797acfc6eb84e1eefcf5 (diff)
downloadguix-patches-249deec95fbf291c50e8fda74cf83f8e0109bd0b.tar
guix-patches-249deec95fbf291c50e8fda74cf83f8e0109bd0b.tar.gz
gnu: eid-mw: Update to 4.4.13.
* gnu/packages/security-token.scm (eid-mw): Update to 4.4.13. [arguments]: Avoid spurious ‘git: command not found’ during build.
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index fb2526c04a..ba5bb5b4c6 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -95,7 +95,7 @@ readers and is needed to communicate with such devices through the
(define-public eid-mw
(package
(name "eid-mw")
- (version "4.4.3")
+ (version "4.4.13")
(source
(origin
(method git-fetch)
@@ -103,7 +103,7 @@ readers and is needed to communicate with such devices through the
(url "https://github.com/Fedict/eid-mw")
(commit (string-append "v" version))))
(sha256
- (base32 "1h90iz4l85drchpkmhlsvg7f9abhw6890fdr9x5n5ir3kxikwcdm"))))
+ (base32 "14bgn2k0xbd6241qdghg787pgxy7k9rvcspaf74zwwyibaqknzyx"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -130,7 +130,7 @@ readers and is needed to communicate with such devices through the
;; Patch it to just return the real version number directly.
(substitute* "scripts/build-aux/genver.sh"
(("/bin/sh") (which "sh"))
- (("\\$GITDESC") ,version))
+ (("^(GITDESC=).*" match) (string-append match ,version "\n")))
(invoke "sh" "./bootstrap.sh"))))))
(synopsis "Belgian eID Middleware")
(description "The Belgian eID Middleware is required to authenticate with