summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-12 22:00:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 22:00:52 +0100
commit12878d12acccf83ef3258a53a01f851088f0aa9e (patch)
tree47f875b50bd7714251256475317e96f4e6d73f55 /gnu/packages/security-token.scm
parent17c3e0d85d9c1a6b4c09d09dd9238297b6165a2f (diff)
parent7b046b1bdc0b1cbc50428d4e08136a110f0a12af (diff)
downloadguix-patches-12878d12acccf83ef3258a53a01f851088f0aa9e.tar
guix-patches-12878d12acccf83ef3258a53a01f851088f0aa9e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 400c053048..fb2526c04a 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages tex)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml))
(define-public ccid
@@ -307,3 +308,36 @@ and other operations. It includes a library and a command-line tool.")
;; license for that one file. Please see it for details. The vast
;; majority of files are licensed under bsd-2.
(license license:bsd-2)))
+
+(define-public yubikey-personalization
+ (package
+ (name "yubikey-personalization")
+ (version "1.19.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://developers.yubico.com/" name
+ "/Releases/ykpers-" version ".tar.gz"))
+ (sha256
+ (base32
+ "104lc0nnqdr365fa7c4vrq67rxp1dp8idndsh9jlhnj9dnhszj1b"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list (string-append "--with-udevrulesdir="
+ (assoc-ref %outputs "out")
+ "/lib/udev/rules.d"))))
+ (inputs
+ `(("json-c" ,json-c)
+ ("libusb" ,libusb)
+ ;; The library "libyubikey" is also known as "yubico-c".
+ ("libyubikey" ,libyubikey)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("eudev" ,eudev)))
+ (home-page "https://developers.yubico.com/yubikey-personalization/")
+ (synopsis "Library and tools to personalize YubiKeys")
+ (description
+ "The YubiKey Personalization package contains a C library and command
+line tools for personalizing YubiKeys. You can use these to set an AES key,
+retrieve a YubiKey's serial number, and so forth.")
+ (license license:bsd-2)))