summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-01-24 18:03:32 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-24 23:09:09 +0100
commitff8b5a3ae7e62b43ad712b9d496bc84664ecfb73 (patch)
tree92a0e3855d81deae088cdf101c3061939603a337 /gnu/packages/search.scm
parent259a94e98102f4ad6988098229ee85c7bb648b36 (diff)
downloadguix-patches-ff8b5a3ae7e62b43ad712b9d496bc84664ecfb73.tar
guix-patches-ff8b5a3ae7e62b43ad712b9d496bc84664ecfb73.tar.gz
gnu: Add hyperestraier.
* gnu/packages/search.scm (hyperestraier): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index cb8b670757..e2342266d6 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +20,7 @@
(define-module (gnu packages search)
#:use-module ((guix licenses)
- #:select (gpl2 gpl2+ gpl3+ bsd-3 x11))
+ #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -160,6 +161,33 @@ accounting for new lines and paragraph changes. It also has robust support
for parsing HTML files.")
(license gpl3+)))
+(define-public hyperestraier
+ (package
+ (name "hyperestraier")
+ (version "1.4.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://fallabs.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qk3pxgzyrpcz5qfyd5xs2hw9q1cbb7j5zd4kp1diq501wcj2vs9"))))
+ (inputs
+ `(("qdbm" ,qdbm)
+ ("zlib" ,zlib)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (home-page "http://fallabs.com/hyperestraier")
+ (synopsis "Full-text search system")
+ (description "Hyper Estraier can be used to integrate full-text
+search into applications, using either the provided command line and CGI
+interfaces, or a C API.")
+ (license lgpl2.1+)))
+
(define-public mlocate
(package
(name "mlocate")