summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 21:28:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:22 +0200
commit9947dcd746deaacf239f51eff06cf6faa523060b (patch)
treee29d6c259e918f6f9f384d277cfe1372e9e9ef45 /gnu/packages/search.scm
parent642d2db55a9adcf9ed94d283c84ad94e2c33cedf (diff)
downloadguix-patches-9947dcd746deaacf239f51eff06cf6faa523060b.tar
guix-patches-9947dcd746deaacf239f51eff06cf6faa523060b.tar.gz
gnu: libtocc: Return #t from all phases.
* gnu/packages/search.scm (libtocc)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases. Re-indent.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index e176fd1aa7..e9e74817f2 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -126,24 +126,24 @@ rich set of boolean query operators.")
(inputs `(("unqlite" ,unqlite)))
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before
- 'configure 'chdir-source
- (lambda _ (chdir "libtocc/src")))
- (replace
- 'check
- (lambda _
- (with-directory-excursion "../tests"
- (and (zero? (system* "./configure"
- (string-append "CONFIG_SHELL="
- (which "sh"))
- (string-append "SHELL="
- (which "sh"))
- "CPPFLAGS=-I../src"
- (string-append
- "LDFLAGS=-L../src/.libs "
- "-Wl,-rpath=../src/.libs")))
- (zero? (system* "make"))
- (zero? (system* "./libtocctests")))))))))
+ (add-before 'configure 'chdir-source
+ (lambda _
+ (chdir "libtocc/src")
+ #t))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "../tests"
+ (invoke "./configure"
+ (string-append "CONFIG_SHELL="
+ (which "sh"))
+ (string-append "SHELL="
+ (which "sh"))
+ "CPPFLAGS=-I../src"
+ (string-append
+ "LDFLAGS=-L../src/.libs "
+ "-Wl,-rpath=../src/.libs"))
+ (invoke "make")
+ (invoke "./libtocctests")))))))
(home-page "https://t-o-c-c.com/")
(synopsis "Tool for Obsessive Compulsive Classifiers")
(description