summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-08 04:08:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-10-19 17:00:51 +0100
commit6de9dfce80b1afd9d934925938661048c3526b03 (patch)
tree5dfc4d76dccd02aab68583e2888644665a5fbfa6 /gnu/packages/search.scm
parent16a23d4ad27d3149a307e5fd1f3bebe81ee4dc3f (diff)
downloadguix-patches-6de9dfce80b1afd9d934925938661048c3526b03.tar
guix-patches-6de9dfce80b1afd9d934925938661048c3526b03.tar.gz
gnu: xapian: Update to 1.4.0.
* gnu/packages/search.scm (xapian): Update to 1.4.0. [source]: Use https URL. [home-page]: Use https URL. [arguments]: Remove 'patch-remotetcp-harness' phase. Replace 'check' phase with a list of custom test targets.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 367d7e6c6f..5d7def5b2f 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -35,30 +35,38 @@
(define-public xapian
(package
(name "xapian")
- (version "1.2.21")
+ (version "1.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://oligarchy.co.uk/xapian/" version
+ (uri (string-append "https://oligarchy.co.uk/xapian/" version
"/xapian-core-" version ".tar.xz"))
(sha256
- (base32 "0grd2s6gf8yzqwdaa50g57j9d81mxkrrpkyldm2shgyizdc8gx33"))))
+ (base32 "0xv4da5rmqqzkkkzx2v3jwh5hz5zxhd2b7m8x30fk99a25blyn0h"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)
("util-linux" ,util-linux)))
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-remotetcp-harness
+ (replace 'check
+ ;; As of Xapian 1.3.3, the TCP server implementation uses
+ ;; getaddrinfo(). This does not work in the build environment,
+ ;; so exclude those tests. See HACKING for the list of targets.
(lambda _
- (substitute* "tests/harness/backendmanager_remotetcp.cc"
- (("/bin/sh") (which "sh"))))))))
+ (zero? (system* "make"
+ "check-inmemory"
+ "check-remoteprog"
+ ;"check-remotetcp"
+ "check-multi"
+ "check-glass"
+ "check-chert")))))))
(synopsis "Search Engine Library")
(description
"Xapian is a highly adaptable toolkit which allows developers to easily
add advanced indexing and search facilities to their own applications. It
supports the Probabilistic Information Retrieval model and also supports a
rich set of boolean query operators.")
- (home-page "http://xapian.org/")
+ (home-page "https://xapian.org/")
(license (list gpl2+ bsd-3 x11))))
(define-public libtocc