summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-05-12 10:28:04 -0500
committerEric Bavier <bavier@member.fsf.org>2015-05-12 10:28:28 -0500
commit6ad2e17e8e44064c22c79b530a02fcc78ae85b5b (patch)
treee9775e104efefc510e6baa40233282a7a3943c3d /gnu/packages/search.scm
parent1600544a1089d2d79841fa693f0b2a8ba19540fa (diff)
downloadguix-patches-6ad2e17e8e44064c22c79b530a02fcc78ae85b5b.tar
guix-patches-6ad2e17e8e44064c22c79b530a02fcc78ae85b5b.tar.gz
gnu: Add bool.
* gnu/packages/search.scm (bool): New variable.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 5886c6a9ea..55ce45b30d 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -124,4 +124,26 @@ files and directories.")
command line tool for interacting with libtocc.")
(license gpl3+)))
+(define-public bool
+ (package
+ (name "bool")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/bool/bool-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1frdmgrmb509fxbdpsxxw3lvvwv7xm1pavqrqgm4jg698iix6xfw"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/bool")
+ (synopsis "Find files that match a boolean expression")
+ (description
+ "GNU Bool is a utility for finding files that match a boolean expression.
+The boolean operators supported are AND, OR, and NOT. Also supported is the
+NEAR operator for locating two expressions within a short distance from each
+other.")
+ (license gpl3+)))
+
;;; search.scm ends here