summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-07 16:50:48 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-07 16:50:48 +0100
commitfa0c1a21c96626ea054442e92f8d0d0009da8e1f (patch)
tree702c4711744c934278df6b651a8444c4dff07b04 /gnu/packages/sdl.scm
parent058d0251bd14fdbb06ce223bbecc8eb1a0d74382 (diff)
downloadguix-patches-fa0c1a21c96626ea054442e92f8d0d0009da8e1f.tar
guix-patches-fa0c1a21c96626ea054442e92f8d0d0009da8e1f.tar.gz
gnu: sdl-mixer: Fix fluidsynth in dependents.
Fixes <https://bugs.gnu.org/39008>. Reported by Pierre Neidhardt <mail@ambrevar.xyz>. * gnu/packages/sdl.scm (sdl-mixer)[arguments]<#:phases>[fix-fluidsynth]: New phase.
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 727a276dc5..df86d677ee 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -270,7 +270,18 @@ WEBP, XCF, XPM, and XV.")
"--disable-music-flac-shared"
"--disable-music-fluidsynth-shared"
"--disable-music-mod-shared"
- "--disable-music-ogg-shared")))
+ "--disable-music-ogg-shared")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-fluidsynth
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ (("EXTRA_LDFLAGS -lfluidsynth")
+ (string-append "EXTRA_LDFLAGS "
+ "-L"
+ (assoc-ref inputs "fluidsynth")
+ "/lib -lfluidsynth")))
+ #t)))))
(inputs
`(("fluidsynth" ,fluidsynth)
("libflac" ,flac)