summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/sdl.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
downloadguix-patches-1c055d72585bd075e20ad0b41942d501d0b38656.tar
guix-patches-1c055d72585bd075e20ad0b41942d501d0b38656.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index fa126afd92..0962ffe985 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -411,30 +411,30 @@ directory.")
(assoc-ref %build-inputs "sdl-union")))
#:parallel-build? #f ; parallel build fails
#:phases
- (alist-cons-before
- 'configure 'fix-env-and-patch
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "GUILE_AUTO_COMPILE" "0")
- ;; SDL_image needs to dlopen libjpeg in the test suite.
- (setenv "LD_LIBRARY_PATH"
- (string-append (assoc-ref inputs "libjpeg") "/lib"))
- ;; Change the site directory /site/2.0 like Guile expects.
- (substitute* "build-aux/guile-baux/re-prefixed-site-dirs"
- (("\"/site\"") "\"/site/2.0\""))
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-env-and-patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "GUILE_AUTO_COMPILE" "0")
+ ;; SDL_image needs to dlopen libjpeg in the test suite.
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (assoc-ref inputs "libjpeg") "/lib"))
+ ;; Change the site directory /site/2.0 like Guile expects.
+ (substitute* "build-aux/guile-baux/re-prefixed-site-dirs"
+ (("\"/site\"") "\"/site/2.0\""))
- ;; Skip tests that rely on sound support, which is unavailable in
- ;; the build environment.
- (substitute* "test/Makefile.in"
- (("HAVE_MIXER = .*$")
- "HAVE_MIXER = 0\n")))
- (alist-cons-before
- 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server.
- (system (format #f "~a/bin/Xvfb :1 &"
- (assoc-ref inputs "xorg-server")))
- (setenv "DISPLAY" ":1"))
- %standard-phases))))
+ ;; Skip tests that rely on sound support, which is unavailable in
+ ;; the build environment.
+ (substitute* "test/Makefile.in"
+ (("HAVE_MIXER = .*$")
+ "HAVE_MIXER = 0\n"))
+ #t))
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (format #f "~a/bin/Xvfb :1 &"
+ (assoc-ref inputs "xorg-server")))
+ (setenv "DISPLAY" ":1")
+ #t)))))
(synopsis "Guile interface for SDL (Simple DirectMedia Layer)")
(description "Guile-SDL is a set of bindings to the Simple DirectMedia
Layer (SDL). With them, Guile programmers can have easy access to graphics,