summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 11:49:15 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 11:49:15 +0100
commit1052ae5f03de931b52c7a638c8e4f8d8d7093af3 (patch)
tree4913e4a7834f4ad6e44906d814cd46e7c21d981b /gnu/packages/sdl.scm
parent869d69ad3248288ffe30264f5e5bd760792ca758 (diff)
parent788f56b4dc0729e07ad546c5bc9694759c271f09 (diff)
downloadguix-patches-1052ae5f03de931b52c7a638c8e4f8d8d7093af3.tar
guix-patches-1052ae5f03de931b52c7a638c8e4f8d8d7093af3.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm42
1 files changed, 22 insertions, 20 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index bdc9a5b39f..7e9dcd9ba2 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
@@ -34,7 +34,7 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:use-module (gnu packages)
- #:use-module ((guix licenses) #:hide (freetype))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -43,6 +43,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages fcitx)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -110,7 +111,7 @@
library designed to provide low level access to audio, keyboard, mouse,
joystick, and graphics hardware.")
(home-page "https://libsdl.org/")
- (license lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public sdl2
(package (inherit sdl)
@@ -153,7 +154,7 @@ joystick, and graphics hardware.")
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols))
(package-inputs sdl)))
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public libmikmod
(package
@@ -182,7 +183,7 @@ joystick, and graphics hardware.")
"MikMod is able to play a wide range of module formats, as well as
digital sound files. It can take advantage of particular features of your
system, such as sound redirection over the network.")
- (license lgpl2.1)
+ (license license:lgpl2.1)
(home-page "http://mikmod.sourceforge.net/")))
(define-public sdl-gfx
@@ -211,7 +212,7 @@ system, such as sound redirection over the network.")
(description "SDL_gfx provides graphics drawing primitives, rotozoom and
other supporting functions for SDL.")
(home-page "http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx")
- (license zlib)))
+ (license license:zlib)))
(define-public sdl-image
(package
@@ -248,7 +249,7 @@ other supporting functions for SDL.")
supports the following formats: BMP, GIF, JPEG, LBM, PCX, PNG, PNM, TGA, TIFF,
WEBP, XCF, XPM, and XV.")
(home-page "https://www.libsdl.org/projects/SDL_image/")
- (license zlib)))
+ (license license:zlib)))
(define-public sdl-mixer
(package
@@ -303,7 +304,7 @@ and specify it using the @code{SDL_SOUNDFONTS} environment variable. For the
legacy @code{timidity} backend, install a patch set such as @code{freepats}
and set the path to the configuration file with @code{TIMIDITY_CFG}.")
(home-page "https://www.libsdl.org/projects/SDL_mixer/")
- (license zlib)))
+ (license license:zlib)))
(define-public sdl-net
(package
@@ -325,7 +326,7 @@ and set the path to the configuration file with @code{TIMIDITY_CFG}.")
(description "SDL_net is a small, cross-platform networking library for
SDL.")
(home-page "https://www.libsdl.org/projects/SDL_net/")
- (license zlib)))
+ (license license:zlib)))
(define-public sdl-pango
(package
@@ -371,7 +372,7 @@ SDL.")
(description "This library is a wrapper around the Pango library.
It allows you to use TrueType fonts to render internationalized and
tagged text in SDL applications.")
- (license lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public sdl-ttf
(package
@@ -400,7 +401,7 @@ tagged text in SDL applications.")
(synopsis "SDL TrueType font library")
(description "SDL_ttf is a TrueType font rendering library for SDL.")
(home-page "https://www.libsdl.org/projects/SDL_ttf/")
- (license zlib)))
+ (license license:zlib)))
(define* (sdl-union #:optional (packages (list sdl sdl-gfx sdl-net sdl-ttf
sdl-image sdl-mixer)))
@@ -546,21 +547,22 @@ directory.")
(define-public guile-sdl
(package
(name "guile-sdl")
- (version "0.5.2")
+ (version "0.5.3")
(source (origin
(method url-fetch)
(uri
(string-append "mirror://gnu/guile-sdl/guile-sdl-"
- version ".tar.xz"))
+ version ".tar.lz"))
(sha256
(base32
- "0cjgs012a9922hn6xqwj66w6qmfs3nycnm56hyykx5n3g5p7ag01"))))
+ "040gyk3n3yp8i30ngdg97n3083g8b6laky2nlh10jqcyjdd550d6"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("lzip" ,lzip)
+ ("pkg-config" ,pkg-config)
;; Required by test suite.
- ("xorg-server" ,xorg-server)
- ("libjpeg" ,libjpeg-turbo)))
+ ("libjpeg" ,libjpeg-turbo)
+ ("xorg-server" ,xorg-server)))
(inputs
`(("guile" ,guile-2.2)
("sdl-union" ,(sdl-union))))
@@ -621,7 +623,7 @@ directory.")
Layer (SDL). With them, Guile programmers can have easy access to graphics,
sound and device input (keyboards, joysticks, mice, etc.).")
(home-page "https://www.gnu.org/software/guile-sdl/")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-sdl2
(package
@@ -651,7 +653,7 @@ sound and device input (keyboards, joysticks, mice, etc.).")
"Guile-SDL2 provides Guile Scheme bindings for the SDL2 C shared library.
The bindings are written in pure Scheme using Guile's foreign function
interface.")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public guile2.2-sdl2
(package/inherit guile-sdl2
@@ -704,4 +706,4 @@ interface.")
"SDL2-CS provides C# bindings for the SDL2 C shared library.
The C# wrapper was written to be used for FNA's platform support. However, this
is written in a way that can be used for any general C# application.")
- (license zlib))))
+ (license license:zlib))))