summaryrefslogtreecommitdiff
path: root/gnu/packages/scsi.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-12 16:08:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-12 16:44:08 +0200
commitbec13d872de23a0c33b2624d430d928a43c35e11 (patch)
tree30f7faa90f620059a2e8750dc917d1ed854e47d9 /gnu/packages/scsi.scm
parent0f304ba73e3a36af4d05be332fdc8dba3a3739b6 (diff)
downloadguix-patches-bec13d872de23a0c33b2624d430d928a43c35e11.tar
guix-patches-bec13d872de23a0c33b2624d430d928a43c35e11.tar.gz
gnu: sg3-utils: Update to 1.43.
* gnu/packages/scsi.scm (sg3-utils): Update to 1.43. [license]: Add bsd-2.
Diffstat (limited to 'gnu/packages/scsi.scm')
-rw-r--r--gnu/packages/scsi.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/scsi.scm b/gnu/packages/scsi.scm
index 92e2d7af4c..2bb863cad9 100644
--- a/gnu/packages/scsi.scm
+++ b/gnu/packages/scsi.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,7 +19,7 @@
(define-module (gnu packages scsi)
#:use-module ((guix licenses)
- #:select (gpl2+ bsd-3))
+ #:select (gpl2+ bsd-2 bsd-3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -26,14 +27,14 @@
(define-public sg3-utils
(package
(name "sg3-utils")
- (version "1.42")
+ (version "1.43")
(source (origin
(method url-fetch)
(uri (string-append "http://sg.danny.cz/sg/p/sg3_utils-"
version ".tar.xz"))
(sha256
(base32
- "1fg71rj0f1gdjmkj0z8wlv46cf9lryjdyjkbi7fjmssgi5jyvblp"))))
+ "04l58wvncqk6lfh4lashsl3ccsa1114hkd6vwi1h1cbmq2fw9c8v"))))
(build-system gnu-build-system)
(home-page "http://sg.danny.cz/sg/sg3_utils.html")
(synopsis "SCSI device utilities")
@@ -49,6 +50,9 @@ up and down disks (@code{sg_start}), do self tests (@code{sg_senddiag}), parse
sense data (@code{sg_decode_sense}), and perform various other functions. In
addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
- ;; The libsgutils library itself is licensed under bsd-3. Some tools are
- ;; licensed under bsd-3, also. Some tools are licensed under gpl2+.
- (license (list gpl2+ bsd-3))))
+ ;; See README: "All utilities and libraries have either a "2 clause" BSD
+ ;; license or are "GPL-2ed". [...] That BSD license was updated from the
+ ;; "3 clause" to the newer "2 clause" version on 20180119. To save space
+ ;; various source code files refer to a file called "BSD_LICENSE" [...]."
+ ;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
+ (license (list gpl2+ bsd-2 bsd-3))))