summaryrefslogtreecommitdiff
path: root/gnu/packages/scribus.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-13 12:44:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-13 12:44:06 +0200
commit77bdfe2f138e7c074c2eb94de3a44561da39d966 (patch)
tree47f37a39f01d921a84ab1e7b4c67119485039a88 /gnu/packages/scribus.scm
parentf9ccde24606fdb9ea10235e50e5898781eb913ff (diff)
downloadguix-patches-77bdfe2f138e7c074c2eb94de3a44561da39d966.tar
guix-patches-77bdfe2f138e7c074c2eb94de3a44561da39d966.tar.gz
gnu: scribus: Update to 1.5.5.
* gnu/packages/scribus.scm (scribus): Update to 1.5.5. [source]: Remove unnecessary patches and snippet. [description]: Change freetype to FreeType. * gnu/packages/patches/scribus-poppler.patch: Remove file. * gnu/local.mk: Apply removal.
Diffstat (limited to 'gnu/packages/scribus.scm')
-rw-r--r--gnu/packages/scribus.scm80
1 files changed, 14 insertions, 66 deletions
diff --git a/gnu/packages/scribus.scm b/gnu/packages/scribus.scm
index 20795da275..25122c10ae 100644
--- a/gnu/packages/scribus.scm
+++ b/gnu/packages/scribus.scm
@@ -47,7 +47,7 @@
(define-public scribus
(package
(name "scribus")
- (version "1.5.4")
+ (version "1.5.5")
(source
(origin
(method url-fetch)
@@ -55,60 +55,7 @@
version "/scribus-" version ".tar.xz"))
(sha256
(base32
- "00ys0p6h3iq77kh72dkl0qrf7qvznq18qdrgiq10gfxja1995034"))
- (patches (append
- ;; Scribus relies heavily on Poppler internals, which have
- ;; changed a lot since the latest Scribus release (2018-04).
- ;; Thus, we require a bunch of patches to stay compatible.
- (search-patches "scribus-poppler.patch")
- (list (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/scribusproject/scribus/commit/"
- "7d4ceeb5cac32287769e3c0238699e0b3e56c24d.patch"))
- (file-name "scribus-poppler-0.64.patch")
- (sha256
- (base32
- "1kr27bfzkpabrh42nsrrvlqyycdg9isbavpaa5spgmrhidcg02xj")))
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/scribusproject/scribus/commit/"
- "76561c1a55cd07c268f8f2b2fea888532933700b.patch"))
- (file-name "scribus-poppler-config.patch")
- (sha256
- (base32
- "01k18xjj82c3ndzp89dlpfhhdccc8z0acf8b04r592jyr5y9rc19")))
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/scribusproject/scribus/commit/"
- "8e05d26c19097ac2ad5b4ebbf40a3771ee6faf9c.patch"))
- (file-name "scribus-poppler-0.69.patch")
- (sha256
- (base32
- "1avdmsj5l543j0irq18nxgiw99n395jj56ih5dsal59fn0wbqk42")))
- (origin
- (method url-fetch)
- (uri (string-append "https://git.archlinux.org/svntogit/"
- "community.git/plain/trunk/scribus-"
- "poppler-0.70.patch?h=packages/scribus&id="
- "8ef43ee2fceb0753ed5a76bb0a11c84775898ffc"))
- (file-name "scribus-poppler-0.70.patch")
- (sha256
- (base32
- "0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr"))))))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each (lambda (file)
- (substitute* file
- ;; These are required for compatibility with Poppler 0.71.
- (("GBool") "bool") (("gTrue") "true") (("gFalse") "false")
- ;; ...and this for Poppler 0.72.
- (("getCString") "c_str")))
- (find-files "scribus/plugins/import/pdf"))
- #t))))
+ "0w9zzsiaq3f7vpxybk01c9z2b4qqg67mzpyfb2gjchz8dhdb423r"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test target
@@ -118,9 +65,9 @@
(modify-phases %standard-phases
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Fix "ImportError: No module named _sysconfigdata_nd" where
- ;; Scribus checks PATH and eventually runs system's Python
- ;; instead of package's.
+ ;; Fix "ImportError: No module named _sysconfigdata_nd"
+ ;; runtime error where Scribus checks PATH and eventually
+ ;; runs system's Python instead of package's.
(let* ((out (assoc-ref outputs "out"))
(py2 (assoc-ref inputs "python")))
(wrap-program (string-append out "/bin/scribus")
@@ -161,12 +108,13 @@
(home-page "https://www.scribus.net")
(synopsis "Desktop publishing and page layout program")
(description
- "Scribus is a @dfn{desktop publishing} (DTP) application and can be used
-for many tasks; from brochure design to newspapers, magazines, newsletters and
-posters to technical documentation. Scribus supports professional DTP
-features, such as CMYK color and a color management system to soft proof
-images for high quality color printing, flexible PDF creation options,
-Encapsulated PostScript import/export and creation of four color separations,
-import of EPS/PS and SVG as native vector graphics, Unicode text including
-right to left scripts such as Arabic and Hebrew via freetype.")
+ "Scribus is a @dfn{desktop publishing} (DTP) application and can
+be used for many tasks; from brochure design to newspapers, magazines,
+newsletters and posters to technical documentation. Scribus supports
+professional DTP features, such as CMYK color and a color management
+system to soft proof images for high quality color printing, flexible
+PDF creation options, Encapsulated PostScript import/export and
+creation of four color separations, import of EPS/PS and SVG as native
+vector graphics, Unicode text including right to left scripts such as
+Arabic and Hebrew via FreeType.")
(license license:gpl2+)))