summaryrefslogtreecommitdiff
path: root/gnu/packages/scribus.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-15 12:31:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-15 23:47:34 +0200
commit1a753d5673b7613727177cb1d3b4c7e343534545 (patch)
tree367afa0abfe27a1245efadab8a2d6c976732a0cb /gnu/packages/scribus.scm
parente9b27c70e3b4bca441d5c2d9f5b743da3cce182a (diff)
downloadguix-patches-1a753d5673b7613727177cb1d3b4c7e343534545.tar
guix-patches-1a753d5673b7613727177cb1d3b4c7e343534545.tar.gz
gnu: poppler: Update to 0.77.0.
* gnu/packages/patches/inkscape-poppler-0.76.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/inkscape.scm (inkscape)[source](patches): New field. * gnu/packages/patches/texlive-bin-luatex-poppler-compat.patch: Add two new hunks. * gnu/packages/pdf.scm (poppler): Update to 0.77.0. * gnu/packages/tex.scm (texlive-bin)[source]: Update Arch patches. [arguments]: Adjust accordingly. * gnu/packages/scribus.scm (scribus)[source](patches): Add two new origins.
Diffstat (limited to 'gnu/packages/scribus.scm')
-rw-r--r--gnu/packages/scribus.scm29
1 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/scribus.scm b/gnu/packages/scribus.scm
index 5b770fd696..322a096414 100644
--- a/gnu/packages/scribus.scm
+++ b/gnu/packages/scribus.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -97,9 +98,33 @@
(file-name "scribus-poppler-0.70.patch")
(sha256
(base32
- "0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr"))))
-
+ "0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr")))
+ ;; This and the preceding patch are taken from Arch Linux
+ ;; because they are adjusted for the Scribus release tarball
+ ;; rather than the upstream master branch.
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.archlinux.org/svntogit/"
+ "community.git/plain/trunk/scribus-"
+ "poppler-0.75.patch?h=packages/scribus&id="
+ "4d35c4ad4869c1dcce9243c4786ff303bdd5c601"))
+ (file-name "scribus-poppler-0.75.patch")
+ (sha256
+ (base32
+ "1lhf2srp7iv44zzdbr3kqa0lfjmm77nalxnx80jqaixhr5yq2s8f")))
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/scribusproject/scribus/commit/"
+ "9449265592a5195153d72c2a511d2010b0cf5b0b.patch"))
+ (file-name "scribus-poppler-0.76.patch")
+ (sha256
+ (base32
+ "0zghiqra9s6f6v06fdr97gdhiw41zr8r6vqh4ar4yw7rqn2771jd"))))
(search-patches "scribus-poppler-0.73.patch")))
+ ;; The --binary flag is required for 'scribus-poppler-0.75.patch', because
+ ;; we need to retain the CRLF line endings.
+ (patch-flags '("-p1" "--binary"))
(modules '((guix build utils)))
(snippet
'(begin