summaryrefslogtreecommitdiff
path: root/gnu/packages/screen.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@member.fsf.org>2014-04-06 14:36:31 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-23 08:09:33 -0400
commitf4eae897cb31a1f3d6d10a42ef67710bf395057d (patch)
tree801b76cbf1b93ce1d14cfc978050bb7dc53fb78f /gnu/packages/screen.scm
parent1790739c756e69e6879419b2d15bc027877b2ac3 (diff)
downloadguix-patches-f4eae897cb31a1f3d6d10a42ef67710bf395057d.tar
guix-patches-f4eae897cb31a1f3d6d10a42ef67710bf395057d.tar.gz
gnu: Add dtach.
gnu/packages/screen.scm (dtach): New variable.
Diffstat (limited to 'gnu/packages/screen.scm')
-rw-r--r--gnu/packages/screen.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index ae03220cc3..8fc17e18b0 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -57,3 +57,34 @@ then manages the different virtual terminals, allowing you to easily switch
between them, to detach them from the current session, or even splitting the
view to show two terminals at once.")
(license gpl2+)))
+
+(define-public dtach
+ (package
+ (name "dtach")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/dtach/dtach-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1agjp08zxxxfni62sqx9qsd9526yqwlz7ry07lfq3clavyylwq8n"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; No install target.
+ '(#:phases (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (copy-file "dtach" (string-append out "/bin/dtach"))))
+ %standard-phases)
+ ;; No check target.
+ #:tests? #f))
+ (home-page "http://dtach.sourceforge.net/")
+ (synopsis "Emulates the detach feature of screen")
+ (description
+ "dtach is a tiny program that emulates the detach feature of screen,
+allowing you to run a program in an environment that is protected from the
+controlling terminal and attach to it later.")
+ (license gpl2+)))