summaryrefslogtreecommitdiff
path: root/gnu/packages/screen.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-23 03:11:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-23 17:16:41 +0200
commit9e2992116213ef16b947ef371d8cd0e93f39de44 (patch)
tree3352af9bb58bd8d5575be8d50105353b16baf9be /gnu/packages/screen.scm
parentf868276b8af13ab577fffd41da5da33076e0665e (diff)
downloadguix-patches-9e2992116213ef16b947ef371d8cd0e93f39de44.tar
guix-patches-9e2992116213ef16b947ef371d8cd0e93f39de44.tar.gz
gnu: byobu: Update to 5.127.
* gnu/packages/screen.scm (byobu): Update to 5.127. * gnu/packages/patches/byobu-writable-status.patch: Adjust context accordingly.
Diffstat (limited to 'gnu/packages/screen.scm')
-rw-r--r--gnu/packages/screen.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 940afcc2d5..e41fb80a53 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -102,7 +102,7 @@ controlling terminal and attach to it later.")
(define-public byobu
(package
(name "byobu")
- (version "5.98")
+ (version "5.127")
(source
(origin
(method url-fetch)
@@ -111,11 +111,11 @@ controlling terminal and attach to it later.")
version ".orig.tar.gz"))
(sha256
(base32
- "1s8nh4wbds1nh52i0d1hy1b308jjf4siwpq92lna1zh9ll4x71j5"))
+ "0fznlj454vgxgzfw3avmvvjpawggs66da5l8k6v0lnzzd75wgbsb"))
(patches (search-patches "byobu-writable-status.patch"))))
(build-system gnu-build-system)
(inputs
- `(("python" ,python-wrapper) ;for config and session GUIs
+ `(("python" ,python-wrapper) ; for config and session GUIs
("python-newt" ,newt "python")))
(arguments
`(#:phases
@@ -123,7 +123,7 @@ controlling terminal and attach to it later.")
(add-before
'configure 'provide-locale
(lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))) ;implicit input
+ (let ((libc (assoc-ref inputs "libc"))) ; implicit input
(substitute* "usr/bin/byobu.in"
(("locale") (string-append libc "/bin/locale")))
#t)))