summaryrefslogtreecommitdiff
path: root/gnu/packages/screen.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-08 14:27:32 -0500
committerLeo Famulari <leo@famulari.name>2016-07-16 20:00:53 -0400
commit334c00f2bcc4de5df3de35dfefed3183c5cfdf66 (patch)
tree717e7c1237f1e230a6c5365047c399540f14cf17 /gnu/packages/screen.scm
parenta1537ac2bae1d7eae39188317daf1186a673e6a2 (diff)
downloadguix-patches-334c00f2bcc4de5df3de35dfefed3183c5cfdf66.tar
guix-patches-334c00f2bcc4de5df3de35dfefed3183c5cfdf66.tar.gz
gnu: Add reptyr.
* gnu/packages/screen.scm (reptyr): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/screen.scm')
-rw-r--r--gnu/packages/screen.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index db8da0ae30..e3f97f4b68 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,3 +143,30 @@ as folding room dividers. The Byobu software includes an enhanced profile,
configuration utilities, and system status notifications for the GNU Screen
window manager as well as the Tmux terminal multiplexer.")
(license gpl3+)))
+
+(define-public reptyr
+ (package
+ (name "reptyr")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nelhage/reptyr/archive"
+ "/reptyr-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07pfl0rkgm8m3f3jy8r9l2yvnhf8lgllpsk3mh57mhzdxq8fagf7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/nelhage/reptyr")
+ (synopsis "Tool for reparenting a running program to a new terminal")
+ (description
+ "reptyr is a utility for taking an existing running program and attaching
+it to a new terminal. Started a long-running process over @code{ssh}, but have
+to leave and don't want to interrupt it? Just start a @code{screen}, use
+reptyr to grab it, and then kill the @code{ssh} session and head on home.")
+ (license expat)))