summaryrefslogtreecommitdiff
path: root/gnu/packages/screen.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-27 15:01:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-27 15:01:38 +0200
commit0306cdd8f5bab73b7dfe50610a243d58f56be579 (patch)
tree8d7fd26d69ae69197e45d34baab74ac466894c46 /gnu/packages/screen.scm
parent083158425914e9a17a241c451a4e254f4656bb02 (diff)
downloadguix-patches-0306cdd8f5bab73b7dfe50610a243d58f56be579.tar
guix-patches-0306cdd8f5bab73b7dfe50610a243d58f56be579.tar.gz
gnu: screen: Update to 4.9.0.
* gnu/packages/screen.scm (screen): Update to 4.9.0. [source]: Remove one patch. [native-inputs]: Remove input labels. Add autoconf, automake. * gnu/packages/patches/screen-CVE-2021-26937.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/screen.scm')
-rw-r--r--gnu/packages/screen.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index d244ed1434..5e7708be6e 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -29,6 +29,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages hurd)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -39,18 +40,17 @@
(define-public screen
(package
(name "screen")
- (version "4.8.0")
+ (version "4.9.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/screen/screen-"
version ".tar.gz"))
- (patches (search-patches "screen-hurd-path-max.patch"
- "screen-CVE-2021-26937.patch"))
+ (patches (search-patches "screen-hurd-path-max.patch"))
(sha256
- (base32 "18ascpjzsy70h6hk7wpg8zmzjwgdyrdr7c6z4pg5z4l9hhyv24bf"))))
+ (base32 "1x1hqy4h47i7hk85f779lkwkm7gkq8h8mxwd0znkh5adpf0m4czr"))))
(build-system gnu-build-system)
(native-inputs
- `(("makeinfo" ,texinfo)))
+ (list autoconf automake texinfo))
(inputs
(list ncurses perl))
(arguments